PMS Screw needing adjustment again??? - Star Motorcycle Forums: Star Raider, V-Max, V-Star, Road-Star Forum
 
LinkBack Thread Tools Display Modes
post #1 of 3 (permalink) Old 04-20-2017, 05:32 PM Thread Starter
Premium Member
 
LoupGarou's Avatar
 
Join Date: Jan 2015
Location: South Louisiana
Posts: 98
PMS Screw needing adjustment again???

Brief history, rejeted carb, set PMS as per the wiki page at 2.5 turns out and the bike ran great for over a year. The idle droped on the bike, missing at idle and popping when letting off throttle, signs of running lean. I realize that once the PMS screws are set no further adjustment should be needed but I thought I would check anyway and sure enough, on the rear carb the idle picked up when I turned the screw and the bike ran great until yesterday when the same symptoms reoccured, idle droped on the bike, missing at idle and popping when letting off throttle.

I pulled the carbs today, removed the PMS screw and could not identify anything that could be causing the problem, I then blew the screw hole out with the compressor and ordered the Maxair PMS screws. Is there anything else that I should do before reassembly?

Thanks,

2005 V Star 1100 Classic, Mustang seats, Baron ORK, risers and Star handlebar, AIS removed, muffler baffles removed and replaced with 1.5" tail pipe, SS front brake cables, run/turn/brake light controller, modulating headlight, pods installed in air box.

Last edited by LoupGarou; 04-20-2017 at 05:34 PM.
LoupGarou is offline  
Sponsored Links
Advertisement
 
post #2 of 3 (permalink) Old 05-09-2017, 07:29 AM Thread Starter
Premium Member
 
LoupGarou's Avatar
 
Join Date: Jan 2015
Location: South Louisiana
Posts: 98
Back together after blowing out the pms port with a compressor and installing the Maxair jets and although it is better there is still some backfire when down shifting and slowing. I guess I will pull the carbs again, disassemble and soak them in carb cleaner. I might wait till the heat of summer, weather is just too nice right now to be down.

2005 V Star 1100 Classic, Mustang seats, Baron ORK, risers and Star handlebar, AIS removed, muffler baffles removed and replaced with 1.5" tail pipe, SS front brake cables, run/turn/brake light controller, modulating headlight, pods installed in air box.
LoupGarou is offline  
post #3 of 3 (permalink) Old 06-01-2017, 07:49 AM Thread Starter
Premium Member
 
LoupGarou's Avatar
 
Join Date: Jan 2015
Location: South Louisiana
Posts: 98
Together again after disassembly and a thorough cleaning and bike is running great.

2005 V Star 1100 Classic, Mustang seats, Baron ORK, risers and Star handlebar, AIS removed, muffler baffles removed and replaced with 1.5" tail pipe, SS front brake cables, run/turn/brake light controller, modulating headlight, pods installed in air box.
LoupGarou is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Star Motorcycle Forums: Star Raider, V-Max, V-Star, Road-Star Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome