lube kit question - Star Motorcycle Forums: Star Raider, V-Max, V-Star, Road-Star Forum
 
LinkBack Thread Tools Display Modes
post #1 of 3 (permalink) Old 05-24-2010, 09:36 AM Thread Starter
Junior Member
 
Join Date: Apr 2010
Posts: 26
lube kit question

we have 4 bike that we ride..No not all at once..My question for you guys is this..Do they sell a kit for lubing your own cables? And is there a danger of lubing too much? SO where can I get one of the lube kits if they are available..No since going to a dealer for this job if I can do my own,right.Thanks for any information you may have to offer...John
tireburner is offline  
Sponsored Links
Advertisement
 
post #2 of 3 (permalink) Old 05-24-2010, 02:00 PM
Senior Member
 
farmalldanzil's Avatar
 
Join Date: Nov 2009
Location: EL Reno OK
Posts: 2,904
Garage
farmalldanzil is offline  
post #3 of 3 (permalink) Old 05-24-2010, 07:47 PM
Senior Member
 
Join Date: Sep 2009
Posts: 1,880
Old school Sugar Bear don't know much about web sites ect, What has worked for me for a day or two is use 30w and let Mr. Newton and his law work for you, it has for me for a while, sometimes simple things will take care of you. Ride Safe.

Ride Safe, Live Long
Sugar Bear is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Star Motorcycle Forums: Star Raider, V-Max, V-Star, Road-Star Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome