2013 slipper clutch problem - Star Motorcycle Forums: Star Raider, V-Max, V-Star, Road-Star Forum
 
LinkBack Thread Tools Display Modes
post #1 of 3 (permalink) Old 07-28-2017, 06:25 AM Thread Starter
Senior Member
 
Darksider's Avatar
 
Join Date: Oct 2011
Location: Blairsville in the N GA mountains
Posts: 108
2013 slipper clutch problem

My 2013 Strat slipper clutch started "slipping" on recent trip to Lake George, NY. Roll on the throttle fairly hard, engine revs then clutch catches. No slippage yet starting out or running through the gears. Bike had fresh Yami semi oil. Stopped a Yamaha dealer in Binghamton, NY who bled clutch line and added new fluid. No change.

So I cut the trip short and now looking for help on the fix. Contact two Yamaha dealers, one is so busy they are not booking any service appointments, the other is willing to schedule in another week or so.

Contacted Tom's Cycle in Cleveland, TN. Tom has worked on Yamaha's for 40+ years. Scheduled to take bike in next week. His suggestion is after determining problem probably doing a Barnett conversion basically reverting back to non-slipper clutch with better components.

Would appreciate input from anyone that has clutch repair experience or had slipper problems and the fix.

Thanks


2013 Colbalt Blue Strat
2009 Stratoliner (new Nov 2011) (retired 2017)
Darkside #115
Venture trunk/backrest
Lindy Hwy Bar
Flanders Touring Bar
Yamaha Light bar w/DayMaker LED lamps
350LM Garmin GPS
Volt gauge
Ultimate seat
Rivco passenger boards
Stebel horn
Braided clutch & brake cables
Clearview windshield w/Memphis shade lowers
SS Cycle oil pressure guage
Superbright 10W LEDS mounted on crashbar
Bridgestone Ecopia 215/55R-17 w/Pirelli Night Dragon front
Darksider is offline  
Sponsored Links
Advertisement
 
post #2 of 3 (permalink) Old 08-08-2017, 09:01 AM
Member
 
The Pondman's Avatar
 
Join Date: Oct 2015
Location: Sunny Florida
Posts: 98
Garage
Quote:
Originally Posted by Darksider View Post
My 2013 Strat slipper clutch started "slipping" on recent trip to Lake George, NY. Roll on the throttle fairly hard, engine revs then clutch catches. No slippage yet starting out or running through the gears. Bike had fresh Yami semi oil. Stopped a Yamaha dealer in Binghamton, NY who bled clutch line and added new fluid. No change.

So I cut the trip short and now looking for help on the fix. Contact two Yamaha dealers, one is so busy they are not booking any service appointments, the other is willing to schedule in another week or so.

Contacted Tom's Cycle in Cleveland, TN. Tom has worked on Yamaha's for 40+ years. Scheduled to take bike in next week. His suggestion is after determining problem probably doing a Barnett conversion basically reverting back to non-slipper clutch with better components.

Would appreciate input from anyone that has clutch repair experience or had slipper problems and the fix.

Thanks
I'll trade your slipper clutch setup for my non - slipper setup with new, uninstalled Barnett Conversion kit.
The Pondman is offline  
post #3 of 3 (permalink) Old 08-08-2017, 04:37 PM Thread Starter
Senior Member
 
Darksider's Avatar
 
Join Date: Oct 2011
Location: Blairsville in the N GA mountains
Posts: 108
Quote:
Originally Posted by The Pondman View Post
I'll trade your slipper clutch setup for my non - slipper setup with new, uninstalled Barnett Conversion kit.
Thanks for the offer but have parts ready to install later this week.
I want to retain the slipper system unless it becomes a ongoing problem.


2013 Colbalt Blue Strat
2009 Stratoliner (new Nov 2011) (retired 2017)
Darkside #115
Venture trunk/backrest
Lindy Hwy Bar
Flanders Touring Bar
Yamaha Light bar w/DayMaker LED lamps
350LM Garmin GPS
Volt gauge
Ultimate seat
Rivco passenger boards
Stebel horn
Braided clutch & brake cables
Clearview windshield w/Memphis shade lowers
SS Cycle oil pressure guage
Superbright 10W LEDS mounted on crashbar
Bridgestone Ecopia 215/55R-17 w/Pirelli Night Dragon front
Darksider is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Star Motorcycle Forums: Star Raider, V-Max, V-Star, Road-Star Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome