Rush Slip on for Stratoliner - needs adjustment - Star Motorcycle Forums: Star Raider, V-Max, V-Star, Road-Star Forum
 
LinkBack Thread Tools Display Modes
post #1 of 10 (permalink) Old 03-22-2011, 09:01 PM Thread Starter
Member
 
Join Date: Sep 2009
Posts: 73
Rush Slip on for Stratoliner - needs adjustment

Put the Rush on the Strat. It sounds awesome but the EXUP Valve is not making the adjustments. I put about 400 miles on with it and the front of the muffler has yellowed. Anyone know what kind of adjustments can be made to fix this?

Thanks, Fitz
mfitz62 is offline  
Sponsored Links
Advertisement
 
post #2 of 10 (permalink) Old 03-23-2011, 07:08 PM
Senior Member
 
linerdave's Avatar
 
Join Date: Sep 2009
Location: N. E. Ohio
Posts: 1,531
Ex up valve

Fitz,

Try disconnecting the battery for a few minutes then reconnecting it. I have seen some reports this will reset the processor and allow it to relearn your map. (The map is mostly the fuel levels at throttle positions. But the processor also controls the Ex Up Valve)

The O2 sensor is just ahead of the muffler be sure it is OK. You did not bump it or disconnectit in the process. Although some run without it.

See if anything here helps
http://www.linerwiki.com/index.php?title=ReinstallEXUP

Dave
linerdave is offline  
post #3 of 10 (permalink) Old 03-24-2011, 09:36 AM Thread Starter
Member
 
Join Date: Sep 2009
Posts: 73
Thanks Dave. I disconnected the battery after installing the muffler, but I only had it off for about 2 minutes. I am wondering now if that was long enough. I can't find any concrete information on how long is long enough. I am sure any computer chip has some kind of back up power, like the digital odometer.

I am wondering if this muffler is free enough that I may have to go to an aftermarket fuel processor??? I will try the battery disconnect again, longer this time, and see how that works. The muffler is discolored now so I don't think I can hurt anything. Last resort I can take to the dealer.

Thanks again, Fitz.
mfitz62 is offline  
Sponsored Links
Advertisement
 
post #4 of 10 (permalink) Old 03-24-2011, 06:59 PM
Senior Member
 
linerdave's Avatar
 
Join Date: Sep 2009
Location: N. E. Ohio
Posts: 1,531
Reset

Fritz,

This guy said 12 to 15 minutes.

http://forums.delphiforums.com/starr...s/?msg=21374.1
Dave
linerdave is offline  
post #5 of 10 (permalink) Old 03-24-2011, 09:25 PM Thread Starter
Member
 
Join Date: Sep 2009
Posts: 73
Thanks Dave. I won't be riding for the next week because our weather has turned crap. It will be no problem leaving the battery unplugged for 15 minutes.

Thanks again. I will post results when I can get back on the road.
mfitz62 is offline  
post #6 of 10 (permalink) Old 03-27-2011, 09:36 AM
Member
 
Join Date: Feb 2011
Posts: 30
I'm interested too in the outcome because I have the same muffler on order. I should be receiveing it after April 1st, it's on backorder for some reason.
Joe
cal55 is offline  
post #7 of 10 (permalink) Old 03-27-2011, 03:49 PM Thread Starter
Member
 
Join Date: Sep 2009
Posts: 73
Don't know where you got yours from Cal, but mine were on backorder for two months. I will hopefully get them re-installed this afternoon and probably won't get to ride until the weekend if the weather permits then.

Fitz.
mfitz62 is offline  
post #8 of 10 (permalink) Old 03-28-2011, 07:23 AM
Member
 
Join Date: Feb 2011
Posts: 30
Hi Fitz,
I called Rush with some questions a few weeks ago and they said they weren't on backorder. So I don't know what the deal is, oh well the price was reasonable so I guess I can wait. It's too cold to ride by me also, as you mentioned next weekends supposed to be warmer.
Joe
cal55 is offline  
post #9 of 10 (permalink) Old 04-21-2011, 08:40 PM
Member
 
Join Date: Feb 2011
Posts: 30
I finally received my Rush slip on muffler, I believe it has a 1.75" baffle. It's not really much louder than stock at idle,until you get on it then it's quite a bit louder,it sounds nice though IMO. A new gasket isn't necessary, I tried to install an OEM Yamaha gasket and there is no way it will fit. I called Rush and they said no gasket was needed but may have to use some kind of high temp sealant if you have a leak and to tighten the clamp to 65 foot lbs. of torque. The installation went pretty smoothly, but if removing the muffler bracket be careful when reinstalling it. It bolts into the frame and the aluminum can strip very easily if the bolts aren't centered correctly. I started to strip mine a little but noticed it early enough to avoid a problem. I ended up re-installing the bracket first and then the muffler.
Joe

Last edited by cal55; 05-03-2011 at 09:11 AM. Reason: Update
cal55 is offline  
post #10 of 10 (permalink) Old 04-21-2011, 08:55 PM
Senior Member
 
damquick1's Avatar
 
Join Date: Nov 2009
Location: Texas Gulf Coast
Posts: 166
FYI ....BlueJob will get rid of that yellowing...just make sure you only use pure silk cloth with it...I had to do it on my previous bike and it actually worked!

2007 Stratoliner Midnight


Proud to have Served with America's Soldiers!
Always Remember 9/11/01
"The Cost of Freedom Just Went Up"
damquick1 is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Star Motorcycle Forums: Star Raider, V-Max, V-Star, Road-Star Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome