cobra powerpro autotune road tested - Star Motorcycle Forums: Star Raider, V-Max, V-Star, Road-Star Forum
 
LinkBack Thread Tools Display Modes
post #1 of 8 (permalink) Old 08-20-2011, 08:26 AM Thread Starter
Member
 
Join Date: Jul 2011
Location: st. charles, mo.
Posts: 53
cobra powerpro autotune road tested

i got my powerpro installed and have close to 100 miles on it. easy install, wire routing requires a little imagination. no tank removal required. just take the two acorn nuts off and raise the rear about an inch with a block of wood. the bike definately has more torque and throttle response from idle on up. it's easier to take off from a dead stop, smoother at low rpm's., and oem exaust slightly throatier. the differences are subtle, but they are an improvement over stock. the bike ran good stock, better than most big v-twins. this just puts the icing on the cake.
snarley bill is offline  
Sponsored Links
Advertisement
 
post #2 of 8 (permalink) Old 08-22-2011, 09:19 AM
Senior Member
 
Join Date: Jan 2010
Location: Michigan
Posts: 254
Let us/me know how your fuel eco is after few tanks. I would like to keep mpg happy. And so far the way I have it I am just looking for something like this to give me bit better performance. Just not willing to pay it at the pump.. None of my buds have a liner and no one trying to race me now so no need to be faster then it is...lol...
Ride Safe
bowhunter4265 is offline  
post #3 of 8 (permalink) Old 08-22-2011, 11:41 AM Thread Starter
Member
 
Join Date: Jul 2011
Location: st. charles, mo.
Posts: 53
Quote:
Originally Posted by bowhunter4265 View Post
Let us/me know how your fuel eco is after few tanks. I would like to keep mpg happy. And so far the way I have it I am just looking for something like this to give me bit better performance. Just not willing to pay it at the pump.. None of my buds have a liner and no one trying to race me now so no need to be faster then it is...lol...
Ride Safe
i have about 600 miles on the autotune. no change in mileage. still up around 48 to 50 mpg. i figured it would be less. guess i'm getting a more efficient burn. if you buy one don't expect a mind blowing improvement. just subtle changes accross the board. smoother, and torqueier. i want to pull a plug and check color . it was pure white before.
snarley bill is offline  
Sponsored Links
Advertisement
 
post #4 of 8 (permalink) Old 08-22-2011, 04:31 PM
Junior Member
 
DerBigE's Avatar
 
Join Date: Aug 2011
Location: Middle GA, USA
Posts: 8
Garage
Snarley Bill,

Interesting about the spark plugs being white before you did the cobra installation. I would like to ask you if you have a certain brand of gasoline that you prefer. I know everybody from time to time will have to refill with a brand they do not like for whatever reason comes up in one's travels. It's just that my plugs where nowhere near white on a factory strat at 8000 miles.

At 55/60 mph, I am getting around 50 MPG. With North GA mountain riding, all bets are off!!


E.
DerBigE is offline  
post #5 of 8 (permalink) Old 08-22-2011, 07:57 PM
Senior Member
 
Join Date: Jan 2010
Location: Michigan
Posts: 254
Wink

Quote:
Originally Posted by snarley bill View Post
i have about 600 miles on the autotune. no change in mileage. still up around 48 to 50 mpg. i figured it would be less. guess i'm getting a more efficient burn. if you buy one don't expect a mind blowing improvement. just subtle changes across the board. smoother, and torqueier. i want to pull a plug and check color . it was pure white before.
Thanks Bill... Only time I get 48 or better, Rides with groups and taking it easy on the twist...lol... I avg around 42, but when the twist gets happy I get around 38. So someone riding same way they rode before and not burning more fuel is a good thing. So I should get same as I have been with bit better power curve.
Ride Safe
Thanks for the reply... Autotune will be on my next toys list.
bowhunter4265 is offline  
post #6 of 8 (permalink) Old 08-23-2011, 08:07 AM Thread Starter
Member
 
Join Date: Jul 2011
Location: st. charles, mo.
Posts: 53
Quote:
Originally Posted by DerBigE View Post
Snarley Bill,

Interesting about the spark plugs being white before you did the cobra installation. I would like to ask you if you have a certain brand of gasoline that you prefer. I know everybody from time to time will have to refill with a brand they do not like for whatever reason comes up in one's travels. It's just that my plugs where nowhere near white on a factory strat at 8000 miles.

At 55/60 mph, I am getting around 50 MPG. With North GA mountain riding, all bets are off!!


E.
i have been running shell v-power 93 octane. could be it's keeping my plugs white. shell , and rotella t6 are my choice of gas and oil for all three of my v-twins. i burn 87 octane shell in my v-star 1300, and 1600 nomad. i have the cobra 2000r processor on both of them. i would like to burn 87 octane in my liner. i need to do some research before i do cuz i have bad hearing and can't here pinging.
snarley bill is offline  
post #7 of 8 (permalink) Old 08-23-2011, 08:46 AM
Senior Member
 
Join Date: Jan 2010
Location: Michigan
Posts: 254
hey bill, bad hearing goes a long way....lol...
I run 87 most of the time, but when its hotter, (90 plus) and I know I am going to run most of tank out in that heat I run premium... bike runs little cooler. mid days I run 89 instead of the cheapest I can get.. Only time it pings at all is when it's hot and I am higher up in the r's... close to 5 and over...
Ride Safe
bowhunter4265 is offline  
post #8 of 8 (permalink) Old 08-23-2011, 09:13 AM Thread Starter
Member
 
Join Date: Jul 2011
Location: st. charles, mo.
Posts: 53
Quote:
Originally Posted by bowhunter4265 View Post
hey bill, bad hearing goes a long way....lol...
I run 87 most of the time, but when its hotter, (90 plus) and I know I am going to run most of tank out in that heat I run premium... bike runs little cooler. mid days I run 89 instead of the cheapest I can get.. Only time it pings at all is when it's hot and I am higher up in the r's... close to 5 and over...
Ride Safe
i want to check with cobra and see what they recommend as far as octane goes with the autotune. i know the 2000r richens the mixture accross the board all the time. i think the autotune only does it when a load is put on the engine. the heavier the load the richer the mixture. so it should run cooler and reduce pinging. i will call their tech help and ask them.
snarley bill is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Star Motorcycle Forums: Star Raider, V-Max, V-Star, Road-Star Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome