Linear control valve - Star Motorcycle Forums: Star Raider, V-Max, V-Star, Road-Star Forum
 
LinkBack Thread Tools Display Modes
post #1 of 7 (permalink) Old 08-25-2015, 01:47 PM Thread Starter
Junior Member
 
Join Date: Aug 2015
Posts: 14
Linear control valve

Hey everyone I have a 2009 roadliner the engine light came on and now I have a code 37 was told it was the linear control valve stuck open. I was told to just remove the value. Is this doable
Biggen67 is offline  
Sponsored Links
Advertisement
 
post #2 of 7 (permalink) Old 08-25-2015, 04:17 PM
Senior Member
 
Join Date: May 2013
Location: Illinois
Posts: 894
Adjust your idle up and see if it goes away. Idle could be too low.

2013 V Star 1300 Deluxe
OEM Tall Sissy Bar
Memphis Shades Fork Deflectors
Bridgestone Exedra Max Belted Tires
Baron's RSTD 7308 bar
sparkn is offline  
post #3 of 7 (permalink) Old 08-25-2015, 04:23 PM Thread Starter
Junior Member
 
Join Date: Aug 2015
Posts: 14
Ok I will try that but I have it idling at 900 to 950 now
Biggen67 is offline  
Sponsored Links
Advertisement
 
post #4 of 7 (permalink) Old 08-25-2015, 06:04 PM
Senior Member
 
Join Date: May 2013
Location: Illinois
Posts: 894
This is the best article I could find for you. A good read and free advice prior to ripping out parts. http://www.fxstein.com/blog/index.ph...e&articleId=47

2013 V Star 1300 Deluxe
OEM Tall Sissy Bar
Memphis Shades Fork Deflectors
Bridgestone Exedra Max Belted Tires
Baron's RSTD 7308 bar
sparkn is offline  
post #5 of 7 (permalink) Old 08-25-2015, 10:46 PM Thread Starter
Junior Member
 
Join Date: Aug 2015
Posts: 14
Hey everyone I have been at it sense 3:00 this afternoon I almost got it all back together all I like is the tank and speedometer and gauges and I have to pick up a can of sea foam tomorrow and back the idle screw back to where I think it was and see what happens from there.i would have finished but the dang mosquito are meaner then I am. Once again thanks for everyone that helped me
Biggen67 is offline  
post #6 of 7 (permalink) Old 08-26-2015, 06:28 PM Thread Starter
Junior Member
 
Join Date: Aug 2015
Posts: 14
I took the three philp head screws out of the LCV and cleaned it up and put back together and put it back on the bike fired it up and it worked for about ten minutes and started idling high again. Looks like I well try the sea foam thing tomorrow
Biggen67 is offline  
post #7 of 7 (permalink) Old 08-27-2015, 08:25 PM Thread Starter
Junior Member
 
Join Date: Aug 2015
Posts: 14
Ok everyone I may not be the sharpest knife in the drawer but I out smarted the ecu on my roadliner. If anyone would like to know how I accomplished the task get back at me
Biggen67 is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Star Motorcycle Forums: Star Raider, V-Max, V-Star, Road-Star Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome