Stumbling on decel - Star Motorcycle Forums: Star Raider, V-Max, V-Star, Road-Star Forum
 1Likes
  • 2 Post By mkhatcher
 
LinkBack Thread Tools Display Modes
post #1 of 1 (permalink) Old 04-30-2017, 08:00 AM Thread Starter
Junior Member
 
Join Date: Apr 2017
Posts: 13
Stumbling on decel

Hi, on my 07 1300 when I decel from anything it sounds fine coming down until a certain rpm (low range ~2.5k?) and then it starts to stumble and sound terrible. I have cobra speedster shorts with quiet baffles. Thinking of going with a EJK kit + K&N filter to help with better flow but wanted to know if y'all have had any similar problems. Thank you
bullboy0852 and bullboy0852 like this.
mkhatcher is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Star Motorcycle Forums: Star Raider, V-Max, V-Star, Road-Star Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome