Virago 535 clutch problem - Star Motorcycle Forums: Star Raider, V-Max, V-Star, Road-Star Forum
 
LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old 03-23-2012, 03:59 PM Thread Starter
Member
 
demian's Avatar
 
Join Date: Feb 2012
Location: Lithuania
Posts: 57
Virago 535 clutch problem

Hi all,

Sorry if this thread is misplaced.
I own a 1995 Yamaha Virago 535. Gonna give it to my girlfriend so want to make sure she doesn't have a brake down in the middle of the road.
Problem is that when bike is in gear and i engage the clutch, the wheel turns REALLY hard (same as with clutch disengaged). Tried to adjust the clutch lever and also near the engine but results are the same.
When i do it on my V-Star 1100, the wheel turns easy so i guess there's a problem with Virago clutch.
Any ideas what could be wrong and where should i start?

2006 Yamaha V-Star 1100 Classic
1995 Yamaha XV535
demian is offline  
Sponsored Links
Advertisement
 
post #2 of 2 (permalink) Old 03-26-2012, 02:15 AM Thread Starter
Member
 
demian's Avatar
 
Join Date: Feb 2012
Location: Lithuania
Posts: 57
Nevermind, gave it a quick spin around the block and now it's working ok. Probably something was stuck.

2006 Yamaha V-Star 1100 Classic
1995 Yamaha XV535
demian is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Star Motorcycle Forums: Star Raider, V-Max, V-Star, Road-Star Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome