WTB: 950 left/clutch side turn signal. - Star Motorcycle Forums: Star Raider, V-Max, V-Star, Road-Star Forum
 
LinkBack Thread Tools Display Modes
post #1 of 6 (permalink) Old 12-28-2011, 08:56 PM Thread Starter
Senior Member
 
Join Date: Mar 2009
Posts: 178
WTB: 950 left/clutch side turn signal.

mine has been dangly since new, and has gotten progressively worse on each ride.

here's the back story:


Quote:
Originally Posted by 04ctd View Post
had a brake switch recall, and I took my Harley to the "stealership" and Sam has started working service (used to be parts)

and I said "my air shocks are losing air, but I messed it with it, so it’s not really the manufacturers fault now, I should have let you fix it in the first place”

he said “been leaking since it was new” I said yes, he said “warranty”


went to pick it up, he said I had a bulb out, and they replaced it…and I was like “um, okay, how much?’
and he said free, warranty.
I was like, nah, it’s maintenance item, I will pay for it.

He said nope, and sent me on my way.

Got home, and realized they had washed it for free too
freaking great deal. never realized how good it felt to ride a shiny nice bike that someone else washed



Took wife’s Yamaha to velocity the next day, and the girl service writer took it in
Oil change, fuel line recall, and dangling turn signal. Been dangly since new, it was the 950 Demo Bike at the old shop on Main Street, but I never took it back in, figured whenever, and would be good.

They never called, so I called them finally.

She said it’s done, was under warranty
I asked about the dangley turn signal
And she said it’s broke
And I said “you said it’s under warranty”
And she said it’s broke
And I said “you said it’s under warranty”
And she said we won’t do fix BROKE stuff under warranty

Long pause for possible comprehension on her part, that…..if it’s broke….and under warranty…uh, duh…you oughta fix it…??

No luck there.

So I asked again, trying to set the stage for her:
“so is the bike under warranty, or not?
..it is..
“is the turn signal broke, or not….?”
..it is…
“so…is the broken turn signal under warranty….or not?”
…no, it’s broken…

(thinking “who’s on first?” at this stage)

Ok, so now we have basic facts, let’s get her to realize a part is broken on a bike that is under warranty.


‘so ok, the bike is in warranty, a part on it is broken, but you can’t fix it…. WHY?”

And she says.
…it’s broken…
“um yeah, we covered this already”
Awkward silence.
“and why….can't you fix parts under warranty?”
…it’s broken….
Awkward silence.
Awkward silence.

At this point, I just don’t know what to say. She’s seems intelligent, and it was too early for her to be drunk or high, so there had to be some reason for her side of the discussion

Awkward silence.
Awkward silence.

“finally she says…it’s broken, like you wrecked the bike, or broke it…it’s not broken like it failed or is a manufacturer defect”

“oh ok, well that’s a valid point. but...It was like that since it was new, it was the demo bike, and it’s always been dangly, and slowly getting worse”

…nope, you broke it, or you wrecked it, and it’s your fault, so you have to pay to have it fixed..

“is Brett still there? We bought it from Brett, and I have pictures of it brand new, with that light hanging low?”
..no, he’s gone, we will not fix it…

“ok, I come get it”


And so now, on a brand new (well, a 09) with 1500 miles, I am shopping for lights

so in the end, the Harley service Dept looked great, and the Yamasaki dealer kinda peeved me off.
o well, just a bike.
04ctd is offline  
Sponsored Links
Advertisement
 
post #2 of 6 (permalink) Old 12-29-2011, 06:52 PM
Senior Member
 
DYNA118's Avatar
 
Join Date: Jan 2011
Location: Paradise Calif.
Posts: 389
Quote:
Originally Posted by 04ctd View Post
mine has been dangly since new, and has gotten progressively worse on each ride.

here's the back story:
Why did'nt you have them fix it when you bought it??
DYNA118 is offline  
post #3 of 6 (permalink) Old 12-29-2011, 08:05 PM
Super Moderator
 
bevo1981's Avatar
 
Join Date: Apr 2009
Location: Austin
Posts: 12,927
it's never too early to be high.
agreed you should have had it fixed before you left the dealership, or at least soon after if you didn't notice it right away so they will know this was on them to fix it. the dealership could have been nice and fixed it for you if you had a pic of its condition before you bought it, but if they can't determine that it's a manufacturer's defect, and it sounds like it wasn't, they can't just go around fixing everybody's stuff for free. especially after you waited as long as you did.

and according to your novel, if that's the way it really went down, that girl should have told you up front that it wasn't covered under warranty because it's not a defect instead of jumping through hoops to get something intelligent out of her.
bevo1981 is offline  
Sponsored Links
Advertisement
 
post #4 of 6 (permalink) Old 01-06-2012, 06:24 PM Thread Starter
Senior Member
 
Join Date: Mar 2009
Posts: 178
Quote:
Originally Posted by bevo1981 View Post
it's never too early to be high.

agreed you should have had it fixed before you left the dealership, or at least soon after.
yeah i guess, it wasn't so bad then, just annoying to me, because i had to look at when it was straight up, and it was more evident

and when the bike leaned over on the stand, and it did not look as bad.

it has just got progressively worse as the bike was ridden (only about 1500 miles on it now) and now it's pretty noticable.

oh well, it's just a bike

i found these, and I think i will do them, they are dual filament,
think i will run one as turn, one as brake.

FULL CHROME ARROW TURN SIGNALS for Yamaha Cruisers

i tore into the rear wiring harness over here:
https://www.starbikeforums.com/forums...ead.php?t=5891

i think the dual filaments would be a real upgrade to any bike: more visible is more better, and that single brake light is not much if a driver is not paying attention
04ctd is offline  
post #5 of 6 (permalink) Old 01-06-2012, 08:52 PM
Senior Member
 
DYNA118's Avatar
 
Join Date: Jan 2011
Location: Paradise Calif.
Posts: 389
Is it actually broken or just loose??
DYNA118 is offline  
post #6 of 6 (permalink) Old 03-26-2012, 10:05 PM Thread Starter
Senior Member
 
Join Date: Mar 2009
Posts: 178
to close out this story:

it was loose, and apparently, they did not look at it, or know how to fix it.

the manager called me a while later, and said "thats crazy, I remember it was a demo, I will personally order you a light, and pay for it out of overhear, no problemo"

so when I picked up the new light, and took the old one off, it fell completely apart...i saw how simple it was to repair, and there was no reason to put the new one.

https://www.starbikeforums.com/forums...8965#post48965

so, the Yamaha dealer did take care of me in the end...just took the long way.
04ctd is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Star Motorcycle Forums: Star Raider, V-Max, V-Star, Road-Star Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome