new 2009 Road Star - Star Motorcycle Forums: Star Raider, V-Max, V-Star, Road-Star Forum
 
LinkBack Thread Tools Display Modes
post #1 of 8 (permalink) Old 02-22-2010, 12:35 PM Thread Starter
Junior Member
 
Join Date: Feb 2009
Location: Jacksonville, Fl
Posts: 19
new 2009 Road Star

The VStar 950 I had was damaged in a parking lot. I just rode home my brand new 2009 Road Star! Now I have to baby it for several hundred miles break in! Did you guys wait till the 600 mile maint check to do an oil change or do it sooner?

Phil....pics forthcoming
__________________
Capri142 is offline  
Sponsored Links
Advertisement
 
post #2 of 8 (permalink) Old 02-22-2010, 06:29 PM
Senior Member
 
linerdave's Avatar
 
Join Date: Sep 2009
Location: N. E. Ohio
Posts: 1,531
Break in

Phil,

Bummer on the damage to the 950, Good move on the RoadStar. My dealer suggested I go the full 600 miles. I only made sure I did not run the bike really hard and not at the same speed for an extended time for the 600 miles.
Dave
linerdave is offline  
post #3 of 8 (permalink) Old 04-13-2010, 11:04 PM
Junior Member
 
Join Date: Apr 2010
Posts: 7
Congrats Capri142! I just got my 09 Roadstar, too. 82 miles on it. What color did you go?
Grinder56 is offline  
Sponsored Links
Advertisement
 
post #4 of 8 (permalink) Old 04-14-2010, 08:36 AM Thread Starter
Junior Member
 
Join Date: Feb 2009
Location: Jacksonville, Fl
Posts: 19
New R*

Here it is
Attached Thumbnails
Click image for larger version

Name:	rs1.jpg
Views:	141
Size:	56.4 KB
ID:	138  
Capri142 is offline  
post #5 of 8 (permalink) Old 04-14-2010, 04:42 PM
Junior Member
 
Join Date: Apr 2010
Posts: 7
Great looking bike. Gonna stick with the stock pipes for awhile?
Grinder56 is offline  
post #6 of 8 (permalink) Old 04-14-2010, 09:27 PM Thread Starter
Junior Member
 
Join Date: Feb 2009
Location: Jacksonville, Fl
Posts: 19
New R*

Yes I'm going to leave it the way it is for awhile. I'm sort of enjoying the quiet...My previous bike had Cobra Longshots which were pretty loud and I really don't want to go back to that
Capri142 is offline  
post #7 of 8 (permalink) Old 04-20-2010, 08:04 PM
Junior Member
 
Join Date: Apr 2010
Posts: 4
Quote:
Originally Posted by Capri142 View Post
The VStar 950 I had was damaged in a parking lot. I just rode home my brand new 2009 Road Star! Now I have to baby it for several hundred miles break in! Did you guys wait till the 600 mile maint check to do an oil change or do it sooner?

Phil....pics forthcoming
__________________
Congrats on the new bike! I just bought a 2009 roadie as well last week, only have 70 mile / 150km on it tho, i would like to ask you a question, when you give yur bike throttle, do you hear a ticking noise and sometimes a harder noise like a klunking as if there were possibly no oil in it? My oil level is good but the noises seem outta place. Dealer says its normal usually until after breakin. what do you think?

Gargrey
Gargrey1700 is offline  
post #8 of 8 (permalink) Old 04-20-2010, 09:02 PM Thread Starter
Junior Member
 
Join Date: Feb 2009
Location: Jacksonville, Fl
Posts: 19
Ticking noise

I get a small ticking noise when i start up the bike, this goes away after awhile. I'm not too concerned about it. seems to be less the more miles I get on the bike
Capri142 is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Star Motorcycle Forums: Star Raider, V-Max, V-Star, Road-Star Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome