Fuel gauge - Star Motorcycle Forums: Star Raider, V-Max, V-Star, Road-Star Forum
 
LinkBack Thread Tools Display Modes
post #1 of 6 (permalink) Old 06-04-2013, 08:15 PM Thread Starter
Junior Member
 
old 300's Avatar
 
Join Date: Oct 2012
Location: Nova Scotia Canada
Posts: 22
Fuel gauge

Just starting to notice that when I fuel up my gauge only goes to 3/4. I fueled tonight gauge showing 1/4 and I only put in 2 gallons. Seems to work ok other than that, no lights flashing or anything. Could this be my fuel sending unit starting to fail? 2003 1600 road star.
old 300 is offline  
Sponsored Links
Advertisement
 
post #2 of 6 (permalink) Old 06-05-2013, 04:23 AM
Senior Member
 
Join Date: May 2012
Location: Collegeville, PA
Posts: 394
Yup, they're prone to fail. There's an eraser fix that works but usually doesn't last. Mine hasn't worked in years, but at less than $20 to fill up, and run to reserve then find a fueling station, it's not that inconvenient.

2001 Yamaha Roadstar
FatJay is offline  
post #3 of 6 (permalink) Old 06-05-2013, 05:57 AM Thread Starter
Junior Member
 
old 300's Avatar
 
Join Date: Oct 2012
Location: Nova Scotia Canada
Posts: 22
Yes I know but I'm one of those that likes to keep everything working like new. Always wanted a fuel gauge on a bike, now I have one its not showing the proper level. Thanks.


Sent from Motorcycle.com Free App
old 300 is offline  
Sponsored Links
Advertisement
 
post #4 of 6 (permalink) Old 06-10-2013, 05:41 AM
Junior Member
 
olskool53's Avatar
 
Join Date: May 2013
Posts: 6
I replaced my sending unit this weekend. Took 45 min tops and it cost me less than $80 shipped. That included new petcock seal and valve packing.
olskool53 is offline  
post #5 of 6 (permalink) Old 06-10-2013, 06:32 AM Thread Starter
Junior Member
 
old 300's Avatar
 
Join Date: Oct 2012
Location: Nova Scotia Canada
Posts: 22
Put some sea foam in my tank a few days ago and yesterday when I fueled the gauge went higher. I will see what happens over the next few fills.


Sent from Motorcycle.com Free App
old 300 is offline  
post #6 of 6 (permalink) Old 08-14-2013, 07:01 PM Thread Starter
Junior Member
 
old 300's Avatar
 
Join Date: Oct 2012
Location: Nova Scotia Canada
Posts: 22
Well I spent the money and installed a new sending unit. Now with a full tank it shows full. Easy fix.


Sent from Motorcycle.com Free App
old 300 is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Star Motorcycle Forums: Star Raider, V-Max, V-Star, Road-Star Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome