Electrical troubleshooting - Star Motorcycle Forums: Star Raider, V-Max, V-Star, Road-Star Forum
 
LinkBack Thread Tools Display Modes
post #1 of 6 (permalink) Old 01-23-2019, 09:45 AM Thread Starter
Junior Member
 
Join Date: Dec 2018
Posts: 27
Electrical troubleshooting

Just an FYI in case it happens to you.
If you lose headlight AND spark simultaneously,go directly to PRIMARY COIL and save yourself some time.
I sure wish someone would have told me!
"Lucy" is all well now,but the weather is not!
RIDE ON , RIDE SAFE
Attached Thumbnails
Click image for larger version

Name:	20190123_101244_1548258212041.jpg
Views:	41
Size:	89.3 KB
ID:	83250   Click image for larger version

Name:	20190123_101213_1548258275393.jpg
Views:	38
Size:	86.2 KB
ID:	83252  
Jo hart is offline  
Sponsored Links
Advertisement
 
post #2 of 6 (permalink) Old 01-23-2019, 10:09 AM
KCW
Senior Member
 
Join Date: Sep 2016
Posts: 5,081
Garage
Im drawing a blank on this

what is the connection between a primary coil failure and the headlight?!
KCW is offline  
post #3 of 6 (permalink) Old 01-23-2019, 10:35 AM Thread Starter
Junior Member
 
Join Date: Dec 2018
Posts: 27
I can't explain the how its connected together , I'm not a mechanic whatsoever.
Perhaps the primary coil has to do something with the headlight relay/diode ?
Everything was normal , then those two issues occurred together.
With stator coil replaced , everything is good.
This is an '06 650.
Jo hart is offline  
Sponsored Links
Advertisement
 
post #4 of 6 (permalink) Old 01-23-2019, 10:50 AM
KCW
Senior Member
 
Join Date: Sep 2016
Posts: 5,081
Garage
I will have to look at the schematics in the service manual and see if I can figure out the connection between the two.

Sometimes things are linked together in a way you would not expect... this is interesting.
KCW is offline  
post #5 of 6 (permalink) Old 01-23-2019, 11:09 AM Thread Starter
Junior Member
 
Join Date: Dec 2018
Posts: 27
I should also add that the entire stator & coil was replaced, even though the stator tested good.
Both coil mounting screws broke upon removal. A good machinist tig welded new bolts to the broken ones to extract them . I then replaced them all with allan heads.(not that I want to go back in there). New stator claims more charging capacity then OEM.
Jo hart is offline  
post #6 of 6 (permalink) Old 01-23-2019, 02:37 PM
Senior Member
 
Join Date: Jun 2017
Location: Ocala, FL
Posts: 447
On my dualsport bike, when I disconnect the headlight, all my indicators and turnsignals stop working, except for the highbeam indicator. Plug it back in and it's back to normal. Sometimes it's just strange.
patrickdk is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Star Motorcycle Forums: Star Raider, V-Max, V-Star, Road-Star Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome