650 Oil Cover Leak - Star Motorcycle Forums: Star Raider, V-Max, V-Star, Road-Star Forum
 
LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old 04-03-2010, 04:46 PM Thread Starter
Junior Member
 
Join Date: Mar 2010
Location: CT
Posts: 22
650 Oil Cover Leak

I changed the oil on my 99 V-Star 650. Drain oil, remove oil cover, change the oil filter, replace the O-ring (put a bit of oil on it before seating it), put it back together annnnnd..............oil leak.

The oil leaks out of the oil filter cover plate. Every time after I ride, I will set it down and notice a few drops on the ground. On the highway, the oil will splatter on the back of the bike. I want to fix this proto.

http://www.msgroup.org/forums/mtt/to...TOPIC_ID=10996 This guy says his plate was warped and had to be resurfaced. This could make sense, as I probably made the screws too tight. Although, I tried removing the plate, reseating it, and tightening it less and I still get a leak.

I know I put the screw back in the right holes, but please does anyone know where the long screws go? I pulled one out from the top right side, and the other long one from the middle. Is this correct? It's possible the screws are in the wrong holes.
PizzaIsLife is offline  
Sponsored Links
Advertisement
 
post #2 of 2 (permalink) Old 04-03-2010, 07:36 PM
Senior Member
 
Join Date: Sep 2009
Posts: 1,880
Quote:
Originally Posted by PizzaIsLife View Post
I changed the oil on my 99 V-Star 650. Drain oil, remove oil cover, change the oil filter, replace the O-ring (put a bit of oil on it before seating it), put it back together annnnnd..............oil leak.

The oil leaks out of the oil filter cover plate. Every time after I ride, I will set it down and notice a few drops on the ground. On the highway, the oil will splatter on the back of the bike. I want to fix this proto.

http://www.msgroup.org/forums/mtt/to...TOPIC_ID=10996 This guy says his plate was warped and had to be resurfaced. This could make sense, as I probably made the screws too tight. Although, I tried removing the plate, reseating it, and tightening it less and I still get a leak.
I know I put the screw back in the right holes, but please does anyone know where the long screws go? I pulled one out from the top right side, and the other long one from the middle. Is this correct? It's possible the screws are in the wrong holes.
May be way off here, but if it didn't leak before, I would lean toward maybe pinched o-ring or a bit of trash on your cover it's self. As for as the screws, I have an old 750 and Yamaha don't seem to change much over the years, I mixed mine up be accident and still no leak or problem, I always put the longest one on the bottom, but if they torque down ok, I really don't know that it matters. My shop manual for the 750 makes no mention of the proper screw location. If you tightened the screws in alternating sequence I don't believe that would warp the cover.

Ride Safe, Live Long
Sugar Bear is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Star Motorcycle Forums: Star Raider, V-Max, V-Star, Road-Star Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome