sluggish start - Star Motorcycle Forums: Star Raider, V-Max, V-Star, Road-Star Forum
 
LinkBack Thread Tools Display Modes
post #1 of 1 (permalink) Old 06-20-2010, 11:51 AM Thread Starter
Junior Member
 
Join Date: Jun 2010
Location: BC, Canada
Posts: 13
Unhappy sluggish start

Hi, I have a 2008 star 1100 and I did a dynojet kit w/stock intake and cobra slip-ons , when I accelerate lightly(0-1/4 throttle)(It is not noticeable if I open the throttle hard) ,there is a noticeable lag until the main jets kick in at about 2000-2500rpm (kinda like its starving for air/fuel).this problem is not present when I swap the stock exhaust back on,obviously has to do with the back pressure that the stock pipes create , but can you point me in the right direction as to a fix.
the bike is stock less the jetting and slip-ons.

I used the dynojet needles and the bigger DJ112(front) & DJ110( rear ) jets, set the clip to 3 groove ( from top) and did not use the additional washer that came w/kit just as they suggested, then had the bike tuned at my break-in tune up and told them that it had been re-jetted and needed to be adjusted( sync'd)

Any help would be much appreciated , thanks to all ( Great site )

Last edited by 2litre; 06-20-2010 at 02:25 PM. Reason: to delete this thread
2litre is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Star Motorcycle Forums: Star Raider, V-Max, V-Star, Road-Star Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome