Cobra FI2000 installation 950? - Star Motorcycle Forums: Star Raider, V-Max, V-Star, Road-Star Forum
 
LinkBack Thread Tools Display Modes
post #1 of 6 (permalink) Old 02-16-2011, 06:06 PM Thread Starter
Junior Member
 
Join Date: Aug 2010
Location: Eagan, MN
Posts: 5
Cobra FI2000 installation 950?

I am trying to install the FI2000 and the instructions are worthless. The instructions say to prop the tank up, for you guys who have installed the FI2000, do you have to remove the tank? I don't see how you can access the fuel injector connectors without removing the tank. Any help would be greatly appreciated.
haile2066 is offline  
Sponsored Links
Advertisement
 
post #2 of 6 (permalink) Old 02-17-2011, 01:24 AM
Super Moderator
 
bevo1981's Avatar
 
Join Date: Apr 2009
Location: Austin
Posts: 12,987
you may not have to remove it entirely, but you definitely need to at least unscrew it from the bottom of the tank near the seat so you can lift it up to give you room to work. i pried up my tank with a piece of wood between the tank and the backbone to raise it up enough to install mine. btw, i had a lot of difficulty installing my connectors since there is not much room in the middle of the engine between the cylinders to put your hands to make the connections. just a fair warning
bevo1981 is online now  
post #3 of 6 (permalink) Old 02-17-2011, 07:54 AM Thread Starter
Junior Member
 
Join Date: Aug 2010
Location: Eagan, MN
Posts: 5
Quote:
Originally Posted by bevo1981 View Post
you may not have to remove it entirely, but you definitely need to at least unscrew it from the bottom of the tank near the seat so you can lift it up to give you room to work. i pried up my tank with a piece of wood between the tank and the backbone to raise it up enough to install mine. btw, i had a lot of difficulty installing my connectors since there is not much room in the middle of the engine between the cylinders to put your hands to make the connections. just a fair warning
Thanks, I finally did get at it. There is zero room under there. By the way, what do you have your setting at?
haile2066 is offline  
Sponsored Links
Advertisement
 
post #4 of 6 (permalink) Old 02-18-2011, 01:58 AM
Super Moderator
 
bevo1981's Avatar
 
Join Date: Apr 2009
Location: Austin
Posts: 12,987
2/4/5. but my exhaust/air intake setup is probably different than yours. i've made numerous adjustments to mine seeing what kinds of different results i get. you just have to find what's best for you. you probably don't need to stray too far away from the settings that come on it from the factory as they are set specific to your bike model and calibrated for an after market exhaust and air system.
bevo1981 is online now  
post #5 of 6 (permalink) Old 04-26-2011, 03:46 PM
Member
 
Join Date: Aug 2010
Posts: 68
Any more words of wisdom on this? I just got my modual today.

Denis
Denis Rule is offline  
post #6 of 6 (permalink) Old 04-26-2011, 10:41 PM
Member
 
Join Date: Aug 2010
Posts: 68
I did the instalation and it toke a little over an hour. The front plug ins are very hard to get at indeed. Tomorrow I'll take the bike out for a run hopefully all that backfire noise is gone.

Denis
Denis Rule is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Star Motorcycle Forums: Star Raider, V-Max, V-Star, Road-Star Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome