check engine light....PLEASE HELP!!! - Star Motorcycle Forums: Star Raider, V-Max, V-Star, Road-Star Forum
 
LinkBack Thread Tools Display Modes
post #1 of 7 (permalink) Old 05-27-2014, 10:18 PM Thread Starter
Junior Member
 
tx08custom's Avatar
 
Join Date: May 2014
Posts: 6
Question check engine light....PLEASE HELP!!!

I just bought my first bike. A 2008 vstar 650 custom and it has less then 3k miles.
I put about 100 miles before the check engine light came on.
I looked online and read the code. It is 6 slow blinks and then 6 fast blinks. I read that it is a decompression fault sensor, but I haven't been able to find anymore info on what to do, new part, etc.
The bike still runs great as there isn't any difference in the motor running at all.
Anyone experienced this and know what to do?

I forgot to add the previous owner added Vance and Hines short shots and rejetted the carb and installed a k&n. If any of that matters.

Thanks

Last edited by tx08custom; 05-27-2014 at 10:25 PM. Reason: left out some details
tx08custom is offline  
Sponsored Links
Advertisement
 
post #2 of 7 (permalink) Old 05-28-2014, 07:25 AM
Senior Member
 
farmalldanzil's Avatar
 
Join Date: Nov 2009
Location: EL Reno OK
Posts: 2,904
Garage
Have a manuel?

Down load this Manuel for free it will help you.
http://www.technohillbilly.net/vstar...0_main_man.pdf
farmalldanzil is offline  
post #3 of 7 (permalink) Old 05-28-2014, 10:01 AM Thread Starter
Junior Member
 
tx08custom's Avatar
 
Join Date: May 2014
Posts: 6
Question

ok, i downloaded the manual. thanks btw. i have tried to do some searching for the fault codes and decompression, and the only thing i have been able to turn up is what was on page 7-49. it states there are fault codes, but doesnt tell you what the fault codes are.

does this bike even have a decompression solenoid?

does anyone know what the 6 slow blinks and 6 fast blinks mean?
tx08custom is offline  
Sponsored Links
Advertisement
 
post #4 of 7 (permalink) Old 05-28-2014, 11:48 AM
Senior Member
 
farmalldanzil's Avatar
 
Join Date: Nov 2009
Location: EL Reno OK
Posts: 2,904
Garage
I have the codes for the 1100 only and I was unable to find them for the 650, The codes I have check the TPS, speed sensor, ignition coils and fuel cut off solenoid valves.
TPS is 3 long
Speed sensor is 4 long
Ignition coil 1 is 33 ==== 3 long pause 3 short
Ignition coil 2 is 34 ==== 3 long pause 4 short
Cutoff 1 is 57 ======== 5 long pause 7 short
Cutoff 2 is 58 ======== 5 long pause 8 short
farmalldanzil is offline  
post #5 of 7 (permalink) Old 05-28-2014, 05:25 PM Thread Starter
Junior Member
 
tx08custom's Avatar
 
Join Date: May 2014
Posts: 6
this is the exact way my check engine light blinks.

http://youtu.be/E8SbijspUyE
tx08custom is offline  
post #6 of 7 (permalink) Old 05-28-2014, 07:12 PM
Senior Member
 
farmalldanzil's Avatar
 
Join Date: Nov 2009
Location: EL Reno OK
Posts: 2,904
Garage
I just read a post that stated if you disconnect the batter it will reset it. ????
farmalldanzil is offline  
post #7 of 7 (permalink) Old 05-30-2014, 01:13 PM Thread Starter
Junior Member
 
tx08custom's Avatar
 
Join Date: May 2014
Posts: 6
Post

i went for a ride for about 30 miles or so last night and no light until i got back home. then the light came back on.
any ideas?

like i said before the bike performance isnt affected at all.
tx08custom is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Star Motorcycle Forums: Star Raider, V-Max, V-Star, Road-Star Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome