Smokey Regulator - Star Motorcycle Forums: Star Raider, V-Max, V-Star, Road-Star Forum
 
LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old 06-09-2014, 08:10 PM Thread Starter
Junior Member
 
Join Date: Jun 2014
Location: Newton County Ga.
Posts: 17
Smokey Regulator

Hi Folks,

I have a 2002 Yamaha VStar 1100 that i have to repair for a friend of mine.

Turn Key ON, Voltage Regulator smokes then main fuse on Power Side Pops. This occurs when the engine is off, same will happen if I start the motor.

Regulator was recently replaced with what I am hoping i is a Rick's Stator.. 6/7 months or 3-5K miles.

I inspected the wire harness and with out opening the sleeve it looks fine, no burned plugs anywhere. My questions is, is the regulator failing or is this the symptom of another issue I need to locate?

I will purchase an OEM regulator unless anyone can suggest a tougher one. I don't want to install it then have it burn out again.

Thank you all for your help!!
Mromaus is offline  
Sponsored Links
Advertisement
 
post #2 of 2 (permalink) Old 06-10-2014, 01:25 PM Thread Starter
Junior Member
 
Join Date: Jun 2014
Location: Newton County Ga.
Posts: 17
Update.
I unplugged the regulator and the fuse did not blow. That tells me the regulator is shot but that doesn't tell me if something shot it.

Thanks again.
Mromaus is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Star Motorcycle Forums: Star Raider, V-Max, V-Star, Road-Star Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome