Bad Boy Horn sounds like a Dead Goose - Star Motorcycle Forums: Star Raider, V-Max, V-Star, Road-Star Forum
 
LinkBack Thread Tools Display Modes
post #1 of 9 (permalink) Old 06-28-2014, 04:00 PM Thread Starter
Senior Member
 
Join Date: Apr 2013
Posts: 466
Bad Boy Horn sounds like a Dead Goose

Have the Chrome WOLO Bad Boy air horn on my V-Star 950. Actually, I got it put on at the dealer. I KNOW it is super easy, it was there for an oil leak and they just did it real quick for cheap and didn't use the wire harness I bought

Worked great last 4 months. I asked if he put the extra fuse in, he didn't and said it wasn't needed and if it breaks, come back.

Anyway, I was driving today and hit it, it WORKS, BUT, sounds like only 1 horn is working, I don't hear the dual horn sound and it is much quieter.

Is this an electrical issue, OR, is it the horn is physically damaged?

Thanks

Not feeling very HORNy right now.

Bandit...............

LA Choppers XXX Big Air Kit, Vance & Hines Big Radius Exhaust, Cobra Fi2000 POWRPRO, Cobra Freeway Bars, Ultimate Seat, D&M HID Headlight, Clevver Clutch Mod, Custom Dynamics LED Turn Signals & Brake Light, Triple Whammy Brake Flasher, Show Chrome Belt Guard, Oil Cap, Frame Covers, Chrome Engine Guard, Brake Reservoir, Chrome Fork Bullets, Chrome Analog Clock, Mustang Tank Bib, Kuryakyn ISO Grips with Chromed Spike Ends, Kuryakyn Chrome Floorboards, Shifter, Brake Cover, WOLO Bad Boy Air Horn
2009VStar950Bandit is offline  
Sponsored Links
Advertisement
 
post #2 of 9 (permalink) Old 06-28-2014, 06:35 PM
Junior Member
 
Join Date: Jun 2014
Location: Gardendale, AL
Posts: 19
My guess is the horn is touching something and not letting it vibrate enough.
2nd possiblilty is wiring is reversed on the horn itself. Sometimes reversed polarity causes no sound or a funny sound.

Larry (2014 950 Tour)
My google photos
willajabir is offline  
post #3 of 9 (permalink) Old 06-28-2014, 06:57 PM Thread Starter
Senior Member
 
Join Date: Apr 2013
Posts: 466
The bottom of the Horn was/is touching resting against the lower Highway Bars by the rear brake pedal, but it IS wired correctly, as it has worked fine for 4 months.

Thanks for sharing possible issue!

LA Choppers XXX Big Air Kit, Vance & Hines Big Radius Exhaust, Cobra Fi2000 POWRPRO, Cobra Freeway Bars, Ultimate Seat, D&M HID Headlight, Clevver Clutch Mod, Custom Dynamics LED Turn Signals & Brake Light, Triple Whammy Brake Flasher, Show Chrome Belt Guard, Oil Cap, Frame Covers, Chrome Engine Guard, Brake Reservoir, Chrome Fork Bullets, Chrome Analog Clock, Mustang Tank Bib, Kuryakyn ISO Grips with Chromed Spike Ends, Kuryakyn Chrome Floorboards, Shifter, Brake Cover, WOLO Bad Boy Air Horn

Last edited by 2009VStar950Bandit; 06-28-2014 at 10:16 PM.
2009VStar950Bandit is offline  
Sponsored Links
Advertisement
 
post #4 of 9 (permalink) Old 06-28-2014, 07:19 PM
Senior Member
 
Tadelk's Avatar
 
Join Date: Oct 2012
Location: Alabama
Posts: 252
Sounds like to me the horn may have an object like bugs or what not in the out put side.


thanks,
Delkster

Thanks,
Todd
2011 Yamaha V-Star Custom 650 ( XVS650AB )

Southern Cruisers Chapter 017 (Southwest Al.)
Tadelk is offline  
post #5 of 9 (permalink) Old 06-29-2014, 06:53 PM
Senior Member
 
Corsair's Avatar
 
Join Date: Mar 2011
Location: Gatineau QC Canada
Posts: 3,650
Garage
I tend to agree with Tadelk. Are the openings on your horn facing forward? If so, try to see if there is a bug, gremlin or a very small alien in there. Not sure how you could dislodge the invader but be carefull not to damage the insides. Hope it helps.

2009 Stratoliner S

A few things added and more stuff to follow


https://sites.google.com/site/vstar1100kb/

Last edited by Corsair; 06-29-2014 at 06:57 PM.
Corsair is offline  
post #6 of 9 (permalink) Old 06-29-2014, 08:49 PM Thread Starter
Senior Member
 
Join Date: Apr 2013
Posts: 466
Update and WOW, you guys are smart! I am NOT SURE what the issue was, but, today the Horn Worked Perfect! I did get stuck in some light rain for a very short time, and water could have gotten in the horn as the opening faces forward, BUT, I assume it was something lodged in there and it somehow came out.

Anyway, it Works!!!!!!!!!!

LA Choppers XXX Big Air Kit, Vance & Hines Big Radius Exhaust, Cobra Fi2000 POWRPRO, Cobra Freeway Bars, Ultimate Seat, D&M HID Headlight, Clevver Clutch Mod, Custom Dynamics LED Turn Signals & Brake Light, Triple Whammy Brake Flasher, Show Chrome Belt Guard, Oil Cap, Frame Covers, Chrome Engine Guard, Brake Reservoir, Chrome Fork Bullets, Chrome Analog Clock, Mustang Tank Bib, Kuryakyn ISO Grips with Chromed Spike Ends, Kuryakyn Chrome Floorboards, Shifter, Brake Cover, WOLO Bad Boy Air Horn
2009VStar950Bandit is offline  
post #7 of 9 (permalink) Old 06-30-2014, 11:33 AM
Member
 
Join Date: Feb 2010
Location: Piedmont, NC
Posts: 84
Do you have any pics of where and how they mounted it?

2009 V Star 950
Cobra slash exhaust
Cobra Fuel Management
Alley Cat Air Cleaner
Low and Mean Speedo face
Low and Mean Coil Cover
Mustang Seat
ebarr is offline  
post #8 of 9 (permalink) Old 06-30-2014, 07:02 PM
Senior Member
 
danman's Avatar
 
Join Date: Apr 2010
Location: Thunder Bay Canada
Posts: 133
I have the wollo bad boy horn mounted to the upper left OEM engine guard bolt. I made a bracket in the shape of an h out of some soft steel then drilled a hole on each end. one end mounts to the horn and the other end goes to the front bolt on the engine guard. you need to use a relay when wiring the horn or it will not sound very loud.

02 Vstar 1100 classic
Samson Warloard Ripsaws
chubby pod kit/maxair pms screws
barons ork
kuryakyn isso grips
breakaway cruise cont.
driver backrest
barons DT risers
barons tackometer
oem passing lights
crome visors on all lights & signals
drag highway pegs
viking studded bags
sissy bar with rack
studded front and rear seats
studded gas tank bib with pouch
clocks for bikes- stem mount
Ram mount& hard wire for GARMIN GPS
Memphis Shades Batwing Fairing
danman is offline  
post #9 of 9 (permalink) Old 07-04-2014, 02:17 PM
Member
 
DaveBall's Avatar
 
Join Date: Jun 2013
Location: Qualicum Beach BC
Posts: 97
#1 reason to use a relay for the Wolo Bad Boy or the original Steibel Nautilus air horn is they pull a whole lot more power than the stock piece of crap that come on all bikes. Wire it properly with at least 14 gauge wire, a relay and a fuse. Don't use the crap plastic relay that comes with the wiring kit. Better yet, don't bother with the kit. Easy enough to make one up yourself.
Get a good quality automotive relay that is suitable for high powered driving lights, a good 15 amp pig tail fuse, some crimp or solder on connectors and a small roll of 14 gauge wire. If you don't know how to wire it, let me know and I can draw you a simple diagram.

You want that horn to get as much power as it needs. If you are using the stock bike wiring, which at best may be 16-18 gauge, you will end up frying the stock wiring as well as the stock horn relay.

Dave
2005 VStar 650
1990 BMW R45
Have had many others.
DaveBall is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Star Motorcycle Forums: Star Raider, V-Max, V-Star, Road-Star Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome