Electrical Question - Star Motorcycle Forums: Star Raider, V-Max, V-Star, Road-Star Forum
 
LinkBack Thread Tools Display Modes
post #1 of 5 (permalink) Old 02-08-2015, 03:47 PM Thread Starter
Junior Member
 
Join Date: Feb 2015
Posts: 3
Electrical Question

Now I was riding home today and on the last leg of my journey my bikes speedometer jumped around, odometer went out, so I decided to try and make it home. But i was losing electrical power to run the fuel pumps and light were dimming. Battery died. I jumped it off so I could take the volts from the electrical system and when running i was getting 13.10 to 13.60 volts. Does it sound like the Battery Old, Stator or something crazy.
CrankN is offline  
Sponsored Links
Advertisement
 
post #2 of 5 (permalink) Old 04-06-2015, 09:10 PM
Member
 
R1madman's Avatar
 
Join Date: Apr 2013
Location: St. Leonard, MD
Posts: 67
Bump. Same thing happened to me tonight. Any ideas on a cause or fix???
R1madman is offline  
post #3 of 5 (permalink) Old 04-07-2015, 05:29 AM
Senior Member
 
nick57's Avatar
 
Join Date: May 2012
Location: erie pa
Posts: 1,446
https://sites.google.com/site/vstar1...harging-system could be the regulater you need to do some diagnosing
nick57 is offline  
Sponsored Links
Advertisement
 
post #4 of 5 (permalink) Old 04-11-2015, 08:31 AM
Member
 
R1madman's Avatar
 
Join Date: Apr 2013
Location: St. Leonard, MD
Posts: 67
Dove into diagnosing the charging system following the info on the wiki page. Battery off and during start up tested out good. Testing the rectifier resulted in no fluctuation in voltage during engine revving. BAD. Went ahead and tested the stator for good measure. Equal readings across all pin combinations. GOOD. Have a heavy duty rectifier on the way. Hopefully this will clear up any future issues.
R1madman is offline  
post #5 of 5 (permalink) Old 04-11-2015, 11:17 AM
Senior Member
 
nick57's Avatar
 
Join Date: May 2012
Location: erie pa
Posts: 1,446
The KB recommends a 05 roadstar reg.rec. stay away from after market.
nick57 is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Star Motorcycle Forums: Star Raider, V-Max, V-Star, Road-Star Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome