XVS950a top speed and acceleration issues - Star Motorcycle Forums: Star Raider, V-Max, V-Star, Road-Star Forum
 3Likes
Reply
 
LinkBack Thread Tools Display Modes
post #1 of 28 (permalink) Old 07-06-2016, 10:39 AM Thread Starter
Junior Member
 
Join Date: Jun 2016
Posts: 12
Question XVS950a top speed and acceleration issues

Hello,

My my motorcycle is Yamaha MidnightStar 950 (2009). The issue is: I cannot get speed higher than 140 kmph (85 mph) with a full throttle on at the 5th gear. I've already changed spark plugs to a new ones, cleaned fuel filter, fuel pump and air filter, checked injectors (was clear as I think), tried to use 92 and 95 octane fuel - but no success. I cannot gain speed. Besides, sometimes when I pull throttle till the end, it feels like loosing power (rpm) on a peak at any gear. What could be the issue?

Last edited by cnekmp; 07-06-2016 at 10:44 AM.
cnekmp is offline  
Sponsored Links
Advertisement
 
post #2 of 28 (permalink) Old 07-06-2016, 01:14 PM
Senior Member
 
pauli466's Avatar
 
Join Date: Feb 2015
Posts: 1,309
Garage
it just did this out of the blue, nothing was modified or touched?

dumb bikers don't get to be old bikers
pauli466 is offline  
post #3 of 28 (permalink) Old 07-06-2016, 02:48 PM Thread Starter
Junior Member
 
Join Date: Jun 2016
Posts: 12
I've purchased this bike at 15.000 km, current run is 18500. I didn't test it's max speed when I've purchased it, but main differences from stock is:
1. I've made a drill mod on stock exhaust (had same issue before the drill mod too)
2. The air filter is K&N

Here is the video where I'm riding on the full throttle at the 5th gear. The speed won't go up above 140 kmph

https://youtu.be/h226dFwa0Kw

Last edited by cnekmp; 07-06-2016 at 03:06 PM.
cnekmp is offline  
Sponsored Links
Advertisement
 
post #4 of 28 (permalink) Old 07-06-2016, 05:59 PM
Senior Member
 
pauli466's Avatar
 
Join Date: Feb 2015
Posts: 1,309
Garage
when i removed a baffle and opened the stock breather slightly on my 650 i lost some mid range torque and top end speed, i had to get more fuel to the engine to get it running perfect again, i don't know if the 950 ecm can be re mapped or re programed, if not a power commander might be the only way get it right, with a power commander and the bike on a dyno it can be dialed in perfect, it's lot easier and faster. it's expensive but it's a one shot deal. you can't really test an injector for a proper spray pattern, they can test fine electrically and be bad mechanically, what i'm saying is clogged injector will test good

dumb bikers don't get to be old bikers
pauli466 is offline  
post #5 of 28 (permalink) Old 07-06-2016, 06:09 PM
Senior Member
 
07midnightcustom's Avatar
 
Join Date: May 2016
Location: pittsburgh
Posts: 203
Agree with pauli. Altho i have no precise knowledge of the 950 if ur basics are in order then do some research to see if you need a programmer or reflash of ecm for running those mods. An injector being fired at a stock pulse width will also test good but the ecm would be firing it based on stock parameters. How is power and performance throughout the rest of your range? Is it only top end that seems lacking?

07 vstar 650 midnight custom
Ais disable, 4.5 inch risers, V&H cruzers, jetted with pods, viking saddlebags, Kuryakyn mini boards and memphis fats windshield, fuel solenoids deleted, star solo seat and 4 inch extensions. Boss audio sound system.
07midnightcustom is offline  
post #6 of 28 (permalink) Old 07-07-2016, 04:21 PM Thread Starter
Junior Member
 
Join Date: Jun 2016
Posts: 12
As far as I feel, the isssue is only at the top end. I'm thinking that there is an issue with injectors or fuel pump. I hadd top speed issues before the drilling the exhaust, so I don't think drilling may cause such problem.
cnekmp is offline  
post #7 of 28 (permalink) Old 07-07-2016, 07:28 PM
Senior Member
 
Sick Mick's Avatar
 
Join Date: Oct 2011
Location: Corona De Tucson, AZ
Posts: 2,181
Changing air filter or drilling a few holes in the exhaust should most likely not cause an issue like that. That stuff normally doesn't change AFR a whole lot.

FI is super nice, until something doesn't work right. Without the proper diagnostic tools, you're just guessing.....and that never seems to work when you have a computer working against you trying to cover up the symptoms.

Please let us know what you find...

Sick Mick* 2006 V Star 1100 Custom

--- Striping, lettering and paint by Sick Mick 6* Tree - 2" extended forks 21" front wheel - HK Sideburners - Progressive rear shock Pods Sick Mick solenoid delete - Spring seat - and other stuff
Sick Mick is offline  
post #8 of 28 (permalink) Old 07-07-2016, 11:14 PM Thread Starter
Junior Member
 
Join Date: Jun 2016
Posts: 12
Quote:
Originally Posted by Sick Mick View Post
Changing air filter or drilling a few holes in the exhaust should most likely not cause an issue like that. That stuff normally doesn't change AFR a whole lot.

FI is super nice, until something doesn't work right. Without the proper diagnostic tools, you're just guessing.....and that never seems to work when you have a computer working against you trying to cover up the symptoms.

Please let us know what you find...
Yes, without computer diagnostics it'll be just a guess and nothing else. Unfortunately our official Yamaha dealer's support sucks. Does anyone could post a link where can I buy Yamaha Diagnostics Cable that will fit xvs950a? I would like to do diagnostics manually.
cnekmp is offline  
post #9 of 28 (permalink) Old 07-08-2016, 09:53 AM
Senior Member
 
commonground's Avatar
 
Join Date: Aug 2013
Location: Windsor Pennsylvania
Posts: 418
Is there a possibility that the Rev Limiter (an ECU function) is causing the problem? Could it be programmed wrong or malfunctioning? Just a thought. Still need the diagnostics.

I'm always working very diligently to discover the obvious.
commonground is offline  
post #10 of 28 (permalink) Old 07-08-2016, 10:05 AM
Senior Member
 
07midnightcustom's Avatar
 
Join Date: May 2016
Location: pittsburgh
Posts: 203
Cool

Or a magic 8 ball...

07 vstar 650 midnight custom
Ais disable, 4.5 inch risers, V&H cruzers, jetted with pods, viking saddlebags, Kuryakyn mini boards and memphis fats windshield, fuel solenoids deleted, star solo seat and 4 inch extensions. Boss audio sound system.
07midnightcustom is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Star Motorcycle Forums: Star Raider, V-Max, V-Star, Road-Star Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome