Part Info -Turn Signal Related - Star Motorcycle Forums: Star Raider, V-Max, V-Star, Road-Star Forum
 
LinkBack Thread Tools Display Modes
post #1 of 5 (permalink) Old 07-31-2016, 12:00 PM Thread Starter
Member
 
Nash40's Avatar
 
Join Date: Oct 2015
Location: Nashville
Posts: 94
Garage
Part Info -Turn Signal Related

So after totalling my car last Thursday my motorcycle starts to have issues with the turn signals flashing like hazard lights on one side.

I tore everything apart and have found the previous owners did install LED turn signals and brake light.

I don't know anything about motorcycles so bear with me.
In the testing I've done it appears the Red module on the left side is bad. (see picture)
The problem is I don't know what it is.
My guess is it's something related to the LED lights that were installed.
I've had this problem in the past but I was able to clear it up by cleaning or drying out the switch on the handlebars.
This time it hasn't worked, so I'm working with the wiring they have under the seat.
I can make either side of the lights work like normal if I connect them using the red module on the right side.
But the left side doesn't do anything.
If anyone knows what it is that would be helpful.
Thanks for the help,
Attached Thumbnails
Click image for larger version

Name:	IMG_20160730_212757757.jpg
Views:	41
Size:	102.5 KB
ID:	61369  

2006 Yamaha Venture
Nash40 is offline  
Sponsored Links
Advertisement
 
post #2 of 5 (permalink) Old 07-31-2016, 08:09 PM Thread Starter
Member
 
Nash40's Avatar
 
Join Date: Oct 2015
Location: Nashville
Posts: 94
Garage
I figured out what it was.
Thank you

2006 Yamaha Venture
Nash40 is offline  
post #3 of 5 (permalink) Old 07-31-2016, 08:26 PM
Senior Member
 
nick57's Avatar
 
Join Date: May 2012
Location: erie pa
Posts: 1,446
what is it some type of resistor?
nick57 is offline  
Sponsored Links
Advertisement
 
post #4 of 5 (permalink) Old 07-31-2016, 09:29 PM Thread Starter
Member
 
Nash40's Avatar
 
Join Date: Oct 2015
Location: Nashville
Posts: 94
Garage
Quote:
Originally Posted by nick57 View Post
what is it some type of resistor?
Yes,
Its for one side of the turn signals.
The other works fine on either side of the turn signals.
This seems to be the source of my issues so I'm trying to find a replacement.
The problem is there isn't any information on it so I'm guessing on what to replace it with.
Hopefully I won't blow something in the process of fixing it.

2006 Yamaha Venture
Nash40 is offline  
post #5 of 5 (permalink) Old 08-01-2016, 05:07 AM
Senior Member
 
nick57's Avatar
 
Join Date: May 2012
Location: erie pa
Posts: 1,446
its big,so are the wires.if its marked how many ohms maybe radio shack can get you something.do you still have self cancelling turn signals?if these are used to slow down the fast flashing that comes with led turns if you cant get a replacement maybe a two wire flasher would do the same thing.
nick57 is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Star Motorcycle Forums: Star Raider, V-Max, V-Star, Road-Star Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome