oil light - Star Motorcycle Forums: Star Raider, V-Max, V-Star, Road-Star Forum
 3Likes
Reply
 
LinkBack Thread Tools Display Modes
post #1 of 14 (permalink) Old 09-28-2016, 11:31 PM Thread Starter
Member
 
Cummins12V98's Avatar
 
Join Date: Aug 2016
Location: Following the warm weather
Posts: 82
oil light

My oil light has started coming on occasionally. If I let off and re apply throttle it will go off. Any Ideas?

Bike has 25K i am confident it's an electrical problem.

2003 V Star 1100 Classic
Pipes, missing "stuff", re jet, Saddleman seat, ScootMod 6" forward, passenger floorboards, Clevver mod. More to come.
Cummins12V98 is offline  
Sponsored Links
Advertisement
 
post #2 of 14 (permalink) Old 09-29-2016, 04:53 AM
Senior Member
 
shadowride69's Avatar
 
Join Date: Nov 2013
Posts: 524
When is the last time you changed or checked the oil

Sent from my SM-J320P using Tapatalk
shadowride69 is offline  
post #3 of 14 (permalink) Old 09-29-2016, 10:08 AM Thread Starter
Member
 
Cummins12V98's Avatar
 
Join Date: Aug 2016
Location: Following the warm weather
Posts: 82
I changed the oil less than 1,000 miles ago with Yama filter. First time the light came on was the first ride with fresh oil. There seems to be no rime or reason to when it does it. I can let off and re accelerate and it goes out or it has gone out by its self. Oil level is correct, I used 10-40 AMZ/OIL.

2003 V Star 1100 Classic
Pipes, missing "stuff", re jet, Saddleman seat, ScootMod 6" forward, passenger floorboards, Clevver mod. More to come.
Cummins12V98 is offline  
Sponsored Links
Advertisement
 
post #4 of 14 (permalink) Old 09-29-2016, 12:24 PM
Member
 
Worty's Avatar
 
Join Date: Aug 2014
Location: Carrying Place, Ontario, Canada
Posts: 39
If the light coming on when the engine is hot try going to a thicker oil like 20w 50. if the light is coming on when the engine is still cold you may have a bigger issue.

2016 FZ 07

2004 V Star 650 Classic (SOLD)
Vance and Hines Cruzers
Worty is offline  
post #5 of 14 (permalink) Old 09-29-2016, 02:48 PM
Member
 
Bike Merc's Avatar
 
Join Date: May 2015
Posts: 73
Mine did the same thing. I have a 2003 Vstar 1100. That light is an Oil level indicator light only, the indicator part itself is located right next to the battery box. First set your bike stand on a block of wood to make sure the bike is level, then check your oil level. It's one of two things, low oil level or a faulty oil level indicator. My money is on the oil level bud. If it is the indicator its a cheap replacement part.
Bike Merc is offline  
post #6 of 14 (permalink) Old 09-29-2016, 04:01 PM
Senior Member
 
Sick Mick's Avatar
 
Join Date: Oct 2011
Location: Corona De Tucson, AZ
Posts: 2,181
We kind of need to know what kind of bike you have to give an intelligent answer to your question.

Sick Mick* 2006 V Star 1100 Custom

--- Striping, lettering and paint by Sick Mick 6* Tree - 2" extended forks 21" front wheel - HK Sideburners - Progressive rear shock Pods Sick Mick solenoid delete - Spring seat - and other stuff
Sick Mick is offline  
post #7 of 14 (permalink) Old 09-29-2016, 04:23 PM
Senior Member
 
nick57's Avatar
 
Join Date: May 2012
Location: erie pa
Posts: 1,446
Quote:
Originally Posted by Sick Mick View Post
We kind of need to know what kind of bike you have to give an intelligent answer to your question.
his bike is included in his signature, 1100..
nick57 is offline  
post #8 of 14 (permalink) Old 09-30-2016, 07:44 AM
Senior Member
 
Sick Mick's Avatar
 
Join Date: Oct 2011
Location: Corona De Tucson, AZ
Posts: 2,181
lol..... sigs didn't show on my phone, my bad.

Sick Mick* 2006 V Star 1100 Custom

--- Striping, lettering and paint by Sick Mick 6* Tree - 2" extended forks 21" front wheel - HK Sideburners - Progressive rear shock Pods Sick Mick solenoid delete - Spring seat - and other stuff
Sick Mick is offline  
post #9 of 14 (permalink) Old 09-30-2016, 08:40 AM Thread Starter
Member
 
Cummins12V98's Avatar
 
Join Date: Aug 2016
Location: Following the warm weather
Posts: 82
Yes the level is good for sure I have checked it on my stand. I have a shop manual so i will look for the sensor and check the connections.

Is the part sensor just by looking at the bike or is it behind the battery cover?

2003 V Star 1100 Classic
Pipes, missing "stuff", re jet, Saddleman seat, ScootMod 6" forward, passenger floorboards, Clevver mod. More to come.
Cummins12V98 is offline  
post #10 of 14 (permalink) Old 09-30-2016, 03:04 PM
Senior Member
 
Sick Mick's Avatar
 
Join Date: Oct 2011
Location: Corona De Tucson, AZ
Posts: 2,181
Oil sensor and light are an oil level, not pressure sensor. You can get small air bubbles that will trigger it on an 1100, more so if you are using conventional oil. It's most noticed right after an oil change.

If you know the level is good.....and the light goes out or flickers.......I'd just ride it and ignore the light. Once things settle down, it won't come on again. Synthetic oils will reduce the foaming and triggering the light.

Sick Mick* 2006 V Star 1100 Custom

--- Striping, lettering and paint by Sick Mick 6* Tree - 2" extended forks 21" front wheel - HK Sideburners - Progressive rear shock Pods Sick Mick solenoid delete - Spring seat - and other stuff
Sick Mick is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Star Motorcycle Forums: Star Raider, V-Max, V-Star, Road-Star Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome