speedo broke - Star Motorcycle Forums: Star Raider, V-Max, V-Star, Road-Star Forum
Reply
 
LinkBack Thread Tools Display Modes
post #1 of 15 (permalink) Old 07-30-2015, 05:16 PM Thread Starter
Junior Member
 
Join Date: Jul 2015
Location: delray wv
Posts: 8
Angry speedo broke

new from wv,own 1100 custom with broken speedo,how fix?
meatwad 1 is offline  
Sponsored Links
Advertisement
 
post #2 of 15 (permalink) Old 07-30-2015, 06:12 PM
Senior Member
 
nick57's Avatar
 
Join Date: May 2012
Location: erie pa
Posts: 1,440
https://sites.google.com/site/vstar1...le-drive-shaft may be broke by mid shaft you check,without information a guess is as good as an opinion
nick57 is online now  
post #3 of 15 (permalink) Old 07-30-2015, 09:31 PM
Super Moderator
 
bevo1981's Avatar
 
Join Date: Apr 2009
Location: Austin
Posts: 12,920


feel free to vote for bike of the month and submit your own for voting

https://www.starbikeforums.com/forums...isplay.php?f=7

and please take our census

https://www.starbikeforums.com/forums...ead.php?t=5655



be sure to ask in the V Star section here

on a steel horse I ride
i create motorcycle videos. check them out here

bevo1981 is online now  
Sponsored Links
Advertisement
 
post #4 of 15 (permalink) Old 07-31-2015, 07:45 AM
eGo
Senior Member
 
Join Date: Apr 2015
Location: Southern MD
Posts: 491
Welcome from Southern MD!!!
eGo is offline  
post #5 of 15 (permalink) Old 07-31-2015, 11:52 AM
Senior Member
 
sonysnek's Avatar
 
Join Date: May 2012
Location: southwestern pa
Posts: 1,409
Welcome from southwestern Pa. Sorry can't help with speedo problem. Did it go all at once or happen slowly over time?

Sonysnek
sonysnek is offline  
post #6 of 15 (permalink) Old 07-31-2015, 11:55 AM Thread Starter
Junior Member
 
Join Date: Jul 2015
Location: delray wv
Posts: 8
thanks for info will check , meaywad 1
meatwad 1 is offline  
post #7 of 15 (permalink) Old 07-31-2015, 11:57 AM Thread Starter
Junior Member
 
Join Date: Jul 2015
Location: delray wv
Posts: 8
thank s for welcome,broke all at once,meatwad1
meatwad 1 is offline  
post #8 of 15 (permalink) Old 07-31-2015, 11:59 AM Thread Starter
Junior Member
 
Join Date: Jul 2015
Location: delray wv
Posts: 8
drive shaft good no issues,mw1
meatwad 1 is offline  
post #9 of 15 (permalink) Old 07-31-2015, 12:05 PM
eGo
Senior Member
 
Join Date: Apr 2015
Location: Southern MD
Posts: 491
What year 1100? Does the odometer on the speedo still work? Is it still counting mileage? Do you still get indicator lights when you turn the key on?

eGo
eGo is offline  
post #10 of 15 (permalink) Old 07-31-2015, 12:06 PM Thread Starter
Junior Member
 
Join Date: Jul 2015
Location: delray wv
Posts: 8
maybe it is speed sensor,mw1
meatwad 1 is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Star Motorcycle Forums: Star Raider, V-Max, V-Star, Road-Star Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome