Yamaha Starbike Forum banner

1 - 9 of 9 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
Hi everyone, I'm new to this, I have a 2007 vstar classic 1100, just wondering if it's normal to have bugs inside my air filter, just bought the bike so I'm just getting used to it, not sure how the whole airbox system works on these bikes, any help would be appreciated thanks
 

·
Registered
Joined
·
491 Posts
Welcome from Southern MD!!! I'd be concerned if the bugs were making it past the filter.. But if they're on the outside, it's doing it's job.
 

·
Registered
Joined
·
3 Posts
Discussion Starter #3
Thanks for the info, the bugs were on the inside of the filter. Just wondering if maybe I have something on the intake that fell off and it's letting bugs through, been trying to read up on it but can't find anything. Does anyone know where the intake opening is on these bikes? Maybe under the tank somewhere?
 

·
Registered
Joined
·
1,090 Posts
Are you saying if you pull of the air filter cover or "dogbowl" off and remove the air filter element, there are bugs inside the housing? Just trying to understand exactly what you are telling us. If that's the case how long did the bike sit before you purchased it? That's where I would tend to think they came from.
I would clean them out and if the bike runs properly, not worry about them again.
Lastly, go buy yourself a service manual for it. You can find both printed and downloadable copies online. You will find it invaluable.
 

·
Registered
Joined
·
491 Posts
Yah, that is odd.. The opening to the dog bowl is on the back side between the cylinder heads. If you're looking at it from the side, it's on the back between 9 and 12.

eGo
 
1 - 9 of 9 Posts
Top