Yamaha Starbike Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
13 Posts
Discussion Starter #1
Did a quick search and couldn't fine another thread for this exact issue. Does anyone have a boss audio system setup on a vstar 950? I am having trouble finding a location to mount the amp. It will not fit into the tool compartment under my seat and leads are too short to reach from my handlebars to the saddlebags. Any suggestions? Thanks in advance.
 

·
Registered
Joined
·
104 Posts
I have an 1100.

I removed the little fake carb cover on the LEFT. I replaced it with a Chrome horn cover from a Harley Street Glide. The BOSS MC400 amp fits pretty good inside the horn cover. The wiring runs up the bracket to the frame under the tank. Speakers are mounted on the crash bars, volume knob is mounted to a bolt on the tank for the speedo.
 

·
Registered
Joined
·
13 Posts
Discussion Starter #3
Thanks @turnz. Do you have any pictures of how it looks after install? That cover was my next option of a place to mount, but looking behind it, it already looked full of wires and other devices. Is there a specific year model of the harley street glide that the horn cover works from? and does it mount directly back with the original holes? or did you have to modify the horn cover to make it attach?
 

·
Registered
Joined
·
104 Posts
The 1100 doesn't have wires behind there. It's just the idle control knob.
The horn cover was from a 99 Electroglide. I utilized one bolt hole.

Sent from my SM-N950U using Tapatalk
 
1 - 4 of 4 Posts
Top