Yamaha Starbike Forum banner

1 - 8 of 8 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter #1
Hello guys, I'm new to this forum. I have a 2008 Stratoliner and here lately its been running crazy, intermittently. When I crank it up fist thing in the morning it runs good, and while driving it, it runs good. But when I shut the bike down and try to restart, it doesn't start on first try. The second try it starts but running shabby..low rpm 5/6 hundred then back up to normal. When I give it gas it sputters, sometimes shut off. Once I get it going by giving it more gas than normal, its fine again while driving. Ive changed the plugs and air filter. What could be the problem? Thanks
 

·
Super Moderator "Loose Nut"
Joined
·
8,651 Posts
Welcome from Houston, Texas. Glad you joined us. I chased a similar issue on a friend's bike. After many hours testing different systems, it turned out to be a sticking injector. We found out that if we turned the key on to prime fuel system, do not start for about 30 seconds, then start bike, it started much easier. The internal mechanism of the fuel injector can get gummed up and doesn't want to cycle properly. We ran several tanks if fuel with a high concentration of Seafoam thru the system and after the third tank the issue went away. Give it a try, it's cheap and might fix it. Here's a few interesting threads to check out when you get a chance.






Go to last page for current hunt :

Ride often and safe.
 

·
Registered
Joined
·
6,851 Posts
anytime a gas engine is not running right putting 1 ounce of Seafoam for each gallon of gas is a good default

for any Vstar bike when you first turn the key to run and you hear the fuel pump running, dont start the bike till you hear it stop

on a carbed bike its filling the float bowls (that have evaporated out)

on a fuel injection bike its building the fuel pressure up to what it needs (~40 to 60 psi) for the injectors

EDIT PS: one of the trade offs of a fuel injected motorcycle is when a sensor fails, it can fail in several ways and cause different issues - which makes it hard to diagnose, esp when it only fails when its hot (after the bike has been parked with a hot engine).

What you described does sound like a flooded cylinder from a stuck-open injector like Les said.

Normally a fuel injected engine will hold its fuel pressure after the engine was shut off, sometimes for days. If you hear the fuel pump running when you turn the bike on, and it does it everytime you stop for few minutes, that sounds like the fuel pressure is bleeding off somewhere, thru a stuck injector for example....
 

·
Registered
Joined
·
5 Posts
Discussion Starter #6
Thank you guys for your responses. Still no luck getting it to run right. When I first start in the morning the bike is running great. When I start riding it, after about 15mins. it started to run like crap. Hesitation when you give it throttle, sputtering and stalling at stop lights. I have to open the throttle a little to keep it running at stop lights. But when you give it a lot of throttle taking off from the stop light it responds, it's just when you're cruising is the problem. The next morning I cranked it up and let it idle, 15 minutes later, into the idle, the motor started sputtering and backfiring, then evenly shut down. I've tried sea foam, changed the plugs, air filter, mass airflow sensor and fuel pump, but to no avail. What is it that allows the bike to run superb initially, but after 15 min or so, when the bike warms well, it run like garbage? I'm puzzled.
 

·
Super Moderator "Loose Nut"
Joined
·
8,651 Posts
You bike has a linear control valve / IAC valve that is basically an electronic choke which has a reputation of causing your described issues. If you google "2008 Stratoliner IAC" you will see the issue discussed. The IAC has an internal valve that is electronically opens to "choke" the bike upon initial start up and closes once the engine is warmed up. This valve can stick open and cause issues. The first recommended repair is to ingest Seafoam into vacuum inlet side of IAC. Do the Google Search and let us know if this is the issues you are having. Good luck and keep us informed.
 

·
Registered
Joined
·
43 Posts
I have a 2008 Stratoliner and here lately its been running crazy, intermittently. When I crank it up fist thing in the morning it runs good, and while driving it, it runs good. But when I shut the bike down and try to restart, it doesn't start on first try. The second try it starts but running shabby..low rpm 5/6 hundred then back up to normal. When I give it gas it sputters, sometimes shut off. Once I get it going by giving it more gas than normal, its fine again while driving. Ive changed the plugs and air filter. What could be the problem? Thanks
Same here with my 07 Roadliner. Difference is, mine will exhibit those symptoms after warm up or an extended ride.
 
1 - 8 of 8 Posts
Top