Yamaha Starbike Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
Hello,

Hoping someone can help me out.

I installed forward control extensions on my Vstar. When I got the floorboard back on, and reconnected the brake pushrod, brake fluid leaked out of what I think is the bleeder valve.

Now, there is no pressure to the rear brake.

I attached a pic pointing to the bolt the fluid leaked out of.

I'm new to working on my bike, so any help is appreciated. I'd ride to a shop, but don't feel that's safe without a rear brake.
 

Attachments

·
Registered
Joined
·
342 Posts
Not a very clear pic but that looks like the banjo bolt that attaches the brake line to the master cylinder. If so, make sure it is tight, fill the master cylinder with the recommended brake fluid and bleed the rear brake. That should solve your problem.
 

·
Registered
Joined
·
2,181 Posts
That's the banjo bolt that holds the brake hose in place. Sounds like the bolt probably came loose and allowed fluid to get by. Make sure it is tight...but don't overtighten. If it is tight, you probably need to replace the copper washers on both sides of the hose end.

Whatever you end up with, it's time to bleed the brakes. If it was me....I'd seriously consider draining all the fluid and replacing it. That's something that should be done every couple of years.
 

·
Registered
Joined
·
570 Posts
There's some good videos of youtube on how to do it

It's not hard to do alone, but having another person is helpful.

In newbie terms, you open a valve, push the pedal, close valve. repeat, kind of, lol.
 
1 - 5 of 5 Posts
Top