Yamaha Starbike Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
49 Posts
Discussion Starter #1
Hey all. I am amazed that I can not find peformance cams or a big bore kit. I already have a stage 1 done and I'm almost due for my first service.

So am I missing something here? I appreciate the help.

Also what is it that they do for the first service? I'm wondering because they want like 175 bucks for it. I pride myself of being a really good bike mechanic and although i don't want to do anything to mess up my warranty; if its just a basic oil change and engine nut and bolt check i am more than capable of doing that. What should I do.

So what say you fine fellers...:D

Thanks again.
 

·
Administrator
Joined
·
13,270 Posts
i don't think anyone makes a big bore kit for the 950, and i haven't found anyone that will bore it out. if they did, it would probably be at least $1K and i'm not sure it would be worth it.

besides the oil change, they check everything. or they're supposed to. every nut, bolt, belt, fluid, etc. and supposed to find if anything is out of spec or defective. it's like a 128 point inspection. but who knows what they actually check and what they skip. it doesn't affect your warranty if you do it yourself. i think the warranty just specifies that you're supposed to perform routine maintenance on time and keep everything stock.
 

·
Registered
Joined
·
49 Posts
Discussion Starter #3
Ok thanks Bevo. I was wondering if they pull the valve covers off and check the lash.
 

·
Registered
Joined
·
570 Posts
sscustomcycle was developing/testing cams for the 950s.

Well, they were the last time I looked at their instagram :p
 

·
Registered
Joined
·
49 Posts
Discussion Starter #6
not on the first service. what is the lash?
Its the gap distance of the rocker and valve end.

sscustomcycle was developing/testing cams for the 950s.

Well, they were the last time I looked at their instagram :p
I looked on there site and they didn't list any cams or piston kits.

Last night on the way home i noticed that my clutch seemed to be engaging at the end of the lever. I'll have to adjust it.
 
1 - 6 of 6 Posts
Top