Yamaha Starbike Forum banner

1 - 2 of 2 Posts

·
Registered
Joined
·
22 Posts
Discussion Starter #1
I changed the oil on my 99 V-Star 650. Drain oil, remove oil cover, change the oil filter, replace the O-ring (put a bit of oil on it before seating it), put it back together annnnnd..............oil leak.

The oil leaks out of the oil filter cover plate. Every time after I ride, I will set it down and notice a few drops on the ground. On the highway, the oil will splatter on the back of the bike. I want to fix this proto.

http://www.msgroup.org/forums/mtt/topic.asp?TOPIC_ID=10996 This guy says his plate was warped and had to be resurfaced. This could make sense, as I probably made the screws too tight. Although, I tried removing the plate, reseating it, and tightening it less and I still get a leak.

I know I put the screw back in the right holes, but please does anyone know where the long screws go? I pulled one out from the top right side, and the other long one from the middle. Is this correct? It's possible the screws are in the wrong holes.
 

·
Registered
Joined
·
1,880 Posts
I changed the oil on my 99 V-Star 650. Drain oil, remove oil cover, change the oil filter, replace the O-ring (put a bit of oil on it before seating it), put it back together annnnnd..............oil leak.

The oil leaks out of the oil filter cover plate. Every time after I ride, I will set it down and notice a few drops on the ground. On the highway, the oil will splatter on the back of the bike. I want to fix this proto.

http://www.msgroup.org/forums/mtt/topic.asp?TOPIC_ID=10996 This guy says his plate was warped and had to be resurfaced. This could make sense, as I probably made the screws too tight. Although, I tried removing the plate, reseating it, and tightening it less and I still get a leak.
I know I put the screw back in the right holes, but please does anyone know where the long screws go? I pulled one out from the top right side, and the other long one from the middle. Is this correct? It's possible the screws are in the wrong holes.
May be way off here, but if it didn't leak before, I would lean toward maybe pinched o-ring or a bit of trash on your cover it's self. As for as the screws, I have an old 750 and Yamaha don't seem to change much over the years, I mixed mine up be accident and still no leak or problem, I always put the longest one on the bottom, but if they torque down ok, I really don't know that it matters. My shop manual for the 750 makes no mention of the proper screw location. If you tightened the screws in alternating sequence I don't believe that would warp the cover.
 
1 - 2 of 2 Posts
Top