Yamaha Starbike Forum banner

1 - 8 of 8 Posts

·
Registered
Joined
·
81 Posts
Discussion Starter #1
Last Winter I installed a V & H slip on muffler and installed a Cobra Fi 2000R fuel programer (the open loop model). this set up was excellent except for when I took a long trip (approx 200 miles or longer) the bike would throw a code. I talked to the Cobera technicians and they told me that the unit was performing as it should.
Since then, I have taken the Cobra fuel programmer off and the bike has alot of backfiring and it feels like it lost some power. I have been considering buying the Cobra Fi 2000R fuel programer the closed loop model.
Any suggestions? I hate buying another fuel programmer, but the open loop model have to have the exhaust probe disconnected. I thought the fuel programmer that uses the exhaust probe connected would work better.
Any suggestions or ideas would be helpful.
 

·
Super Moderator
Joined
·
6,367 Posts
I'm running the cobra unit still with the oxygen sensor in place on my 09' 950, and with a cobra slip on, and an open air filter kit, and it runs great. Any mods to your air filter system? One thing I've noticed after the mods I've made is that my bike is a bit more sensitive to what fuel I'm burning. Also double check your settings on the FI 2000R. Hope this helps, and please update us when you find out what's going on.


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
52 Posts
running the cobra unit without the O2 sensor, full cobra slashdowns and a cobra air intake no probs once i got the set up right
how can they tell if its running correctly just over the fone?
 

·
Registered
Joined
·
81 Posts
Discussion Starter #5
I think I will put the cobra unit back on the bike and try "fine tuning" the fuel on the high end. From what I read above, it must be the settings that I am running or the fuel (like keith63 said). I personally thought it was the cobra unit that was causing the problem, but maybe the settings. So, lot of riding and testing. What a great reason for riding !!
Thanks for the input.
 

·
Registered
Joined
·
52 Posts
the settings i received from cobra were nowhere near what it needed to be way too high running very rich, i think i ended up setting it 2.5 , 3 , 3.5
but thats in uk diff climate diff fuel quality
 

·
Super Moderator
Joined
·
6,367 Posts
Climate and fuel can make a difference. At least you have a good reason to ride to fine tune your settings, lol.


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
81 Posts
Discussion Starter #8
I spent yesterday talking to Cobra technicians and doing some research and determined that I did not "fine tune" the Open loop Fi 2000r. When I am traveling 80 plus mph and suddenly let off the fuel, I get a little back firing in the exhaust. The Cobra tech told me that I need to take the main jet pod and increase the setting a little and then go for another ride to check it out. He told me that he thinks that I am getting a code when running 80 plus is because the bike is on the lean side.

So, I am going to re install the unit and "fine tune" it this spring. Also the subject of fuel and altitude was discussed.
 
1 - 8 of 8 Posts
Top