Yamaha Starbike Forum banner

1 - 11 of 11 Posts

·
Registered
Joined
·
1,452 Posts
Discussion Starter #1 (Edited)
the battery is not charging after a long ride my battery monitor said not charging. the battery tested with the bike off is 12.2 volts it's drained a little. withe the engine running it only goes up .2 volts. i tested the stator using the volt setting on the meter and all three wires show 60+ volts. and no continuity to ground.so it's either the rec, reg. or the battery. or a bad connection somewhere. i haven't tested the reg. rec. yet. so if only 12+ volts are coming from the reg. would'nt that be the bad part and not the battery?would a bad ground prevent a battery from receiving full voltage from the reg.rec.
 

·
Registered
Joined
·
447 Posts
It could be a bad battery, but unlikely. If you charge the battery up using an external charger, battery tender or soemthing. Then test it, and show no changes, it is not the battery. If an external charger is not able to charge the battery, the battery is likely bad, but I don't believe this is true in this case.
 

·
Registered
Joined
·
1,452 Posts
Discussion Starter #3
i think the battery is fine. it was at 12.5 volts before the ride and it cranks the bike good.it is ten years old. i'm having it tested tomorrow. the ohm meter attached to the battery terminals only read 12.5 volts. is that the volts coming from the regulator or is that the volts that are going into the battery. i can find no information that says a regulator can put out low volts everything says they fail and put out to many volts.
 

·
Registered
Joined
·
447 Posts
It can fail any number of ways. The normal case for the regulator on these bikes is to fail with high voltage.

If the rectifier fails, you normally loose 1/3 of your power, so it will just not recharge the battery good, and since it isn't recharging as fast, will look like low voltage. This is just annoying to diagnose with a volt meter. You need to test each of the 3 rectifier parts to see if one has failed.

But I believe all these bikes, the regulator and rectifiers come in the same package, so it's just replacing that one part.
 

·
Registered
Joined
·
1,452 Posts
Discussion Starter #6 (Edited)
I took the regulator out and did a check of the diodes one failed. i ordered a regulator for a 2005 roadstar and now it's charging at 14.1 volts. i don't know why it's not in the middle 14s but it's working. i did solder the stator leads. Also replaced the battery.With one diode failing it was charging at 12.5 to 13 volts, enough to maintain the battery. If i did'nt have a battery monitor i would'nt have known about the problem and would have eventually got stranded.
 

·
Registered
Joined
·
5,380 Posts
did the diode fail as an open circuit (infinite resistance) or as a short (near zero ohms)?

Just curious.
 
1 - 11 of 11 Posts
Top