Yamaha Starbike Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
20 Posts
Discussion Starter #1
Hey all,

I just recently replaced my pads all the way around on my 02 1100 with the EBC pads. Let me tell you, what a difference! Unbelievably smooth and quiet.

Uh oh...knew it couldn't last. All of a sudden after about 400-500 miles, the front brakes are squeeking again. I've tried wet sanding the rotors a little bit thinking they just got glazed but that didn't help.

To add to the stack, the weirdest thing is happening with the rear brakes. It sounds like the pads are almost rubbing when taking off and slowing down. Imagine if there was a little hump in the rotor and the pad just brushed over that with every rotation at slower speeds. It's driving me crazy. I can figure it out. The rotors are fine, and the pads are still new. So I'm just confused on what's going on.

If anyone has any tips that would be awesome!

75 and sunny here in Arkansas after a cold past few weeks. Spring is coming!
 

·
Registered
Joined
·
20 Posts
Discussion Starter #3
I've had the rubbing issue on my 1100 before. What I found was the caliper was dirty. All I did was to get some brake cleaner, removethe pads and gave the calipers a good rinsing. I also put some anti sqeal paste to the back of the pads before re-installing them.
Thanks for the reply. So you applied anti squeal to the BACK of the pads? Like the part that goes into the caliper?
 

·
Registered
Joined
·
38 Posts
Thanks for the reply. So you applied anti squeal to the BACK of the pads? Like the part that goes into the caliper?
Yes the antisqueal compound goes on the back of the pads not the friction side. Also on cars we would use a grinding disc and deglaze the rotors..... don't grind away tje rotors just knock the shine off to stop squeals
 
1 - 4 of 4 Posts
Top