Yamaha Starbike Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
359 Posts
Discussion Starter #1
Has anyone here installed ViziTec's "SupaBrake" (brake light modulator) on their 650? I have the part, but don't know where it goes. Surprisingly, the Yamaha dealership has no idea either, nor does the company owner himself! Any help would be greatly appreciated!

Thanks,
Glen

 

·
Registered
Joined
·
1,315 Posts
Has anyone here installed ViziTec's "SupaBrake" (brake light modulator) on their 650? I have the part, but don't know where it goes. Surprisingly, the Yamaha dealership has no idea either, nor does the company owner himself! Any help would be greatly appreciated!

Thanks,
Glen

that unit doesn't look specific to a 650 the rear light plug is square on a 650 and that plug looks oval, if you can't find an adapter you'll might need to cut the plug off and splice the wires into the harness. the brake light harness connector is hooked under a tab on the plastic cover on the side of the battery. the brake light wire is yellow and very thin. on that unit it looks like red goes to the brake light power supply and the yellow goes to the brake light itself and black goes to ground the top plug looks like a switching plug.... to change the flash modes you move the fuse location
 

·
Registered
Joined
·
359 Posts
Discussion Starter #3
that unit doesn't look specific to a 650 the rear light plug is square on a 650 and that plug looks oval, if you can't find an adapter you'll might need to cut the plug off and splice the wires into the harness. the brake light harness connector is hooked under a tab on the plastic cover on the side of the battery. the brake light wire is yellow and very thin. on that unit it looks like red goes to the brake light power supply and the yellow goes to the brake light itself and black goes to ground the top plug looks like a switching plug.... to change the flash modes you move the fuse location
Paul, you are correct... I now see that it is not the right photo of the part for the 650 connection. The one I have has a rectangular plug, not oval. I am told that it is a simple plug-and-play, but I didn't know where on the bike it goes. So now that I know it goes behind the battery cover, I will give it a try tomorrow and report back. I recently installed one on my new Honda CB500FA and it took about five seconds... I hope this one is just as simple!

Thanks,
Glen
 
1 - 3 of 3 Posts
Top