Yamaha Starbike Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter #1
I am trying to install the FI2000 and the instructions are worthless. The instructions say to prop the tank up, for you guys who have installed the FI2000, do you have to remove the tank? I don't see how you can access the fuel injector connectors without removing the tank. Any help would be greatly appreciated.
 

·
Administrator
Joined
·
13,697 Posts
you may not have to remove it entirely, but you definitely need to at least unscrew it from the bottom of the tank near the seat so you can lift it up to give you room to work. i pried up my tank with a piece of wood between the tank and the backbone to raise it up enough to install mine. btw, i had a lot of difficulty installing my connectors since there is not much room in the middle of the engine between the cylinders to put your hands to make the connections. just a fair warning
 

·
Registered
Joined
·
5 Posts
Discussion Starter #3
you may not have to remove it entirely, but you definitely need to at least unscrew it from the bottom of the tank near the seat so you can lift it up to give you room to work. i pried up my tank with a piece of wood between the tank and the backbone to raise it up enough to install mine. btw, i had a lot of difficulty installing my connectors since there is not much room in the middle of the engine between the cylinders to put your hands to make the connections. just a fair warning
Thanks, I finally did get at it. There is zero room under there. By the way, what do you have your setting at?
 

·
Administrator
Joined
·
13,697 Posts
2/4/5. but my exhaust/air intake setup is probably different than yours. i've made numerous adjustments to mine seeing what kinds of different results i get. you just have to find what's best for you. you probably don't need to stray too far away from the settings that come on it from the factory as they are set specific to your bike model and calibrated for an after market exhaust and air system.
 

·
Registered
Joined
·
68 Posts
I did the instalation and it toke a little over an hour. The front plug ins are very hard to get at indeed. Tomorrow I'll take the bike out for a run hopefully all that backfire noise is gone.

Denis
 
1 - 6 of 6 Posts
Top