Yamaha Starbike Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
25 Posts
Discussion Starter #1 (Edited)
... In a great way :) Just added a Cobra Powrflo to my 07 1300. The bike came new from the dealership with some add-ons: Mustang seat, Dragstar straight pipes, and a light bar. Stock air box with those pipes, which, looking back seems a bit odd. Always had some decel popping.

Skip ahead to 2019. Bike was in mothballs for quite a while. Since it had not been stored properly, as I am a Nitwit, it took some doing to get it running again. All was good, but still that popping. So I did what any nitwit would do, and popped an open air kit on. You would think that would make for some dodgy running with those pipes, but...

Nope. No pop. Runs like a top. Funny thing though, the pipes don't seem as loud. Something to do with running lean? I have a Cobra FMS on the way, since absolutely everyone says it's needed with this setup.

OH, and this air kit huffs like an electrolux, for real. The engine is gulping air.

Thoughts from anyone?


Sent from my SM-G965U using Tapatalk
 

·
Registered
Joined
·
200 Posts
I have one on my '14 1300 Tourer and love it.

I did buy a small Ratchet wrench (?), makes it a lot easier to get to the filter for cleaning.
 

·
Registered
Joined
·
986 Posts
If you don't have a FMS or Ivan's flash with your current set up chances are to burn your valves since your bike runs very very lean and ECM stock map does not have proper A/F values for increased air flow. Your best option would be Ivan's flash or professional tune and dyno. I had Stryker with the same engine as yours (1300), same intake, Cobra pipes and some cheap fms module (manual). While FMS module helped some, I highly recommend to get your ECM re-flashed, that way you'll get the top performance.
 

·
Registered
Joined
·
25 Posts
Discussion Starter #5
Thanks, I have a FMS coming tomorrow, and we'll see what that does. For sure that should fix a lean condition, because that's all it's designed for, but a flash may be in the cards too.

Sent from my SM-G965U using Tapatalk
 
1 - 6 of 6 Posts
Top