Yamaha Starbike Forum banner

1 - 6 of 6 Posts

Registered
Joined
33 Posts
Discussion Starter #1
01 Roadstar 1600 Silverado
AIS removed
Cobra slip ons
K&N filter

So I have a few issues, main one is loud popping on decel, which seems to be the PMS from what I've read. All the parts that aren't metal are dry rotted and cracking, worst being the front tire and intake manifold. 馃槬 So I believe I have a good idea of where to start but any feedback is always appreciated. Next time I'm off I should have a new PMS screw and manifold at least, hopefully a tire. I'll wait and tackle everything I can with the tank off, seems the best route.

On the agenda is: tank removal
Carb removal
Carb disassembly and cleaning
PMS screw install
Manifold replacement

Anything else I need to do while I'm in there? I've read through this information several times and I believe it can be a simple task as long as I take my time. That said if you can think of any tips or tricks or advice that's worth telling twice I'd love to hear it, even if I may have already read it.

Oh and all the stuff done to this bike was done by the PO so I don't have a clue if they did any of it correctly.

Sent from my N9519 using Tapatalk
 

Premium Member
Joined
1,155 Posts
I would put a jet and needle kit in it while you are there if you were not already going to do it. Look hard in the tank make sure there is no rust inside. Adjust the valves while the tank is off. Replace anything rubber that you can.
 

Registered
Joined
33 Posts
Discussion Starter #3
The tank is Crystal clear, you can easily see the bottom, very shiny, no rust. Thanks for the help, valves have probably not been adjusted in a long time. Bike has 40000 miles on it, he might've had it done or done it, who knows.

Sent from my N9519 using Tapatalk
 

Registered
Joined
33 Posts
Discussion Starter #5
Yah I know but it helps me keep track of what I've actually read and paid attention to. It'll slow down when I get recent with the forums.

Sent from my N9519 using Tapatalk
 

Registered
Joined
33 Posts
Discussion Starter #6
Fuel guage has been acting up and has now stopped altogether, it shows empty or near empty constantly and sometimes the fuel light is on or it's blinking.

Sent from my N9519 using Tapatalk
 
1 - 6 of 6 Posts
Top