Yamaha Starbike Forum banner

1 - 20 of 33 Posts

·
Registered
Joined
·
13 Posts
Discussion Starter #1
i have a 09 yamaha v star 650 i just bought a batwing fairing for it and it come with the fork clamps and bracket(pic included but it just dont want to go on with their set up.. trying to see if anyone has any ideas or has ran into this same problem with these kits or bracket.. any help or suggests would be really nice spent a chunck of money on it and cant even get it working..i can put one bolt on one side but then the other three do not line up and the oppisite side is like an inch off..
am i missing something or do i need to remove something to mount it.. i have even loosed the headlight and moved the handle bars down..

ANY HELP WOULD BE NICE
 

Attachments

·
Registered
Joined
·
6,851 Posts
I dont have a batwing, but I have a Memphis Shades Fats WS with the quick release mounts - looks similar to your

I found the instructions vague, It would be easy to put parts on upside down from the simple line drawings - but if you are lining up a full inch off I would think you got parts that are not for your bike

if its any consolation it was frustrating putting my WS on, but I figured it out after an hour of going "this cant be right!!!!"
 

·
Registered
2008 Vstar1300
Joined
·
378 Posts
Have you tried mounting the bracket to the fairing first ?? You might have to adjust the position of the clamps after the fairing has the brackets mounted.
 
  • Like
Reactions: Deeksvstarclassic

·
Registered
Joined
·
13 Posts
Discussion Starter #4
Yes that’s how it was when I first recieved it..it really seems like They sent me something wrong but Idk I’ve tried talking to them but everything I say or send them they want more or something different
 

·
Registered
Joined
·
13 Posts
Discussion Starter #5
I dont have a batwing, but I have a Memphis Shades Fats WS with the quick release mounts - looks similar to your

I found the instructions vague, It would be easy to put parts on upside down from the simple line drawings - but if you are lining up a full inch off I would think you got parts that are not for your bike

if its any consolation it was frustrating putting my WS on, but I figured it out after an hour of going "this cant be right!!!!"
Any way u could send me pics of how urs in mounted to ur forks
 

·
Registered
2008 Vstar1300
Joined
·
378 Posts
Are the fork clamps offset as in the mount location is forward or back ? maybe you have them on upside down or reversed .. Looking at the diagram they sent it looks like they should be offset .. lower bolt forward and upper set back.. so bolting would be on a slight angle lifting the fairing upwards. :)
 
  • Like
Reactions: Deeksvstarclassic

·
Registered
2001 VStar 650 Classic
Joined
·
498 Posts
Let me know how you like your batwing fairing, I've been thinking about adding one to my bike with quick release. Also if you do not mind me asking, where did you get it from?.
 

·
Registered
2008 Vstar1300
Joined
·
378 Posts

·
Registered
Joined
·
6,851 Posts
Any way u could send me pics of how urs in mounted to ur forks
here is my Memphis Shades trigger mount from the rear:

93500


its hard to see in the photo, the rubber wrap around the top has a square bumper on it that pushed up tight under the bottom edge of the triple tree top piece

its taking forever for the front photo to upload from my phone thru email....
 

·
Registered
Joined
·
6,851 Posts
here is the front side

93501
 

·
Registered
Joined
·
6,851 Posts
maybe you need to loosen the clamps of the forks, twist them around to where the mounting reaches the HW on the wing?
 

·
Registered
Joined
·
13 Posts
Discussion Starter #12
Yea I switch mine around now and I’m trying that way like in the pic above just waiting for a third hand to grow
 

·
Registered
2008 Vstar1300
Joined
·
378 Posts
Kcw's pictures show the bolts are offset upper is back and low is forward like I said.. I hope this works out for you !!!
 

·
Registered
Joined
·
13 Posts
Discussion Starter #14
See mine don’t have the adjustable clamp mine are two of the same just one have the black rubber piece
 

·
Registered
Joined
·
644 Posts
Do you have a picture of the instructions?
 

·
Registered
Joined
·
2,923 Posts
Flip the bottom clamp over on the one that doesn't let the bottom be forward, it sounds stupid, but you may be getting frustrated and getting tunnel vision
 

·
Registered
Joined
·
13 Posts
Discussion Starter #19
If I don’t have them both the same way then one of them are always angled the wrong way and it binds
 

·
Registered
Joined
·
13 Posts
Discussion Starter #20
Flip the bottom clamp over on the one that doesn't let the bottom be forward, it sounds stupid, but you may be getting frustrated and getting tunnel vision
I ordered a new Memphis quick disconnect for it but with the viruse it’s been delayed but I just figured I was doin something wrong I’m usually pretty good and stuff like this I always do my own work but this one as me puzzled and I think they packed something wrong there were no label on the hardware to even double check them so
 
1 - 20 of 33 Posts
Top