Yamaha Starbike Forum banner

1 - 9 of 9 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
Hey guys and gals,

I am a new member to star bike forums and I just wanted to say whats up. I love going to these forums because you can get your most difficult questions answered and you can talk shop with other yamaha fans. I tried posting a thread in the tech section but it told me I did not have access to that page. I suppose my account has not been fully activated yet.

I know this is not the right forum to post any tech questions, but I am having a problem with my turn signals and i am sort of desperate. I have just installed a set of mini bullet turn signal lights on the vstar and for some reason the lights are all blinking twice as fast as they did before. Now I realize I might need to install a load equalizer but thats only for LED applications. The mini bullets are all incandescent and the rear bulbs are 12v 23/8 watt which is exactly the same as the ones that come stock on the vstar 1100. So if anything I'm guessing I might need a load equalizer on the front turn signals.

Thanks

2009vstar

keep the wheels burnin'!
 

·
Banned
Joined
·
1,741 Posts
I'm guessing I might need a load equalizer on the front turn signals.

Thanks

2009vstar

keep the wheels burnin'!
I'd agree with your assessment. The way the circuit logic is installed, if there is a significantly lower load on or or more turn signals, the bike assumes the bulb is burned out and goes into the "bulb failure rapid flash" mode.

However before you go crazy with a load equalizer, check to ensure that all of the turn signal bulbs are flashing (and doing so on the proper side). If you've loosened a ground or pinched a wire and created a high resistance condition, the turn signal(s) can behave as you've described.

Good luck
 

·
Banned
Joined
·
1,741 Posts
Oh, and one more thing:



:D:D:D

Welcome...:)

(And do NOT vote for the bike of the month! It's a blind link that enrolls you in Bevo's personal escort club:eek:)



Regards...:)
 

·
Registered
Joined
·
3 Posts
Discussion Starter #4
Hey Springer,

Thanks for the help. That image of the big guy in the tutu is a little disturbing.

Thanks again

2009vstar
 

·
Registered
Joined
·
923 Posts
Welcome to the site 2009Vstar! Some real wild people on here but some good info! As you've already been told, I agree with your assessment as well. Have the same problem on a bike I'm rebuilding,
 
1 - 9 of 9 Posts
Top