Yamaha Starbike Forum banner

1 - 8 of 8 Posts

·
Registered
Joined
·
17 Posts
Discussion Starter #4
Thanks for the welcome yes my original engine went out and purchased a salvage 05 custom and had somebody put the engine in their it fit like a glove

Sent from my SPH-L710T using Tapatalk
 

·
Registered
Joined
·
5,436 Posts
how many miles on the motor when it failed?

Timing chain? eat a valve? Curious minds want to know.
 

·
Registered
Joined
·
17 Posts
Discussion Starter #6
the original engine had 21,000 miles on when I let it sit last winter and then I started it up I noticed a clunking sound at startup I attributed it to my starter clutch once running it ran fine used it for about 4 months then my starter clutch went out had it replaced when they started it up the rear cylinder was not firing it was just making a bigger clunking sound they did a pressure test no pressure whatsoever for the amount of money they wanted to open the engine up and see what was going on I just went out and purchased a salvage 05 custom with 22000 miles on it and I just had that engine put in mine so now I got a bunch of extra parts 05 custom I got the whole bike for what they wanted to charge me to look into my engine

Sent from my SPH-L710T using Tapatalk
 

·
Super Moderator
Joined
·
6,086 Posts
Hi Jesse, welcome to the forum. San Berdo eh? Nice area, I'm from right near there. Please post up some pics of your ride, we love pics here. Ride safely!


Sent from my iPhone using Tapatalk
 
1 - 8 of 8 Posts
Top