Yamaha Starbike Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
I ride an '06 V-Star 1100 and used to ride an '05 650. I live in Santa Fe, NM and am excited to dig into all that the forums have to offer. I am only this week getting my bike back from the shop, after encountering the dreaded loose forward shaft nut issue that seems to be common on 02-06 V-Stars. Expensive fix, but she should be good to go now!
 

·
Registered
Joined
·
119 Posts
Welcome!!! Southern Oregon. This is a great knowledge base for anything V-Star 1100. Pretty darn nice people here as well. I have an 02 V-Star 1100. Replaced my regulator/rectifier, and the dreaded Starter Clutch. Ouch, it is a bit pricey, but the smile on my face just won't go away? I don't know why...........
 

·
Moderator
Joined
·
2,797 Posts
Welcome from Atlantic Canada. I have an 1100 too and I've buggered up the threads on the shaft to hopefully save myself that repair (fingers crossed). I also had to replace my rectifier and I'm hoping not to have to do the starter clutch. They fixed that particular issue in 03 or 04 so you shouldn't have to worry about it. Otherwise, excellent bikes. Post a pic of your ride when you get a chance!
 

·
Super Moderator "Loose Nut"
Joined
·
6,032 Posts

·
Super Moderator
Joined
·
6,491 Posts
Hi Goat! Welcome to the forum from East Tennessee. Yes we have several 1100 owners here so you be able to get any 1100 question answered. This is definitely the greatest of all time forum going. Ride safely!


Sent from my iPhone using Tapatalk
 
1 - 6 of 6 Posts
Top