Yamaha Starbike Forum banner
1 - 4 of 4 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
This is my 1st post and have a problem I need help with. 2007 Road Star 1700 , always had starter solenoid relay problems from about 5000 on. Replaced like 7-8 of them? Few yrs. back, replaced with starter and that help. Now the with key turned off the electrical system is on with full lights.? With key turn on , no starter. Ordered a stater solenoid and when unpluged connecters I noticed the 3 prone connecter (white) to the rectifier , (black) engine side, was slightly melted? When looking at it, it's the right prone of the side by side.
 

·
Registered
2008 Yamaha Road Star Silverado (Gray, hard bags, etc.)
Joined
·
884 Posts
Welcome to the site from Iowa.

A few things (probably more questions than answers), if you've replaced that many relays you have other problems. Are these cheap Ebay parts or OEM Yamaha? Some will say not to waste your time with the cheap parts but others have used them with success I suppose.

How does your bike start? A proper tuned bike with a good battery/electrical system should start relatively easy. But if you're hanging on the starter button for long lengths of time that isn't good and can could be contributing to your problem.

On my '08 if the kill switch on the right bar is bumped it won't turn the engine over. So make sure that switch is working. If the lights are on with the key in the OFF position then there may be a relay or other component fried.
 

·
Registered
Joined
·
2,290 Posts
Electrical issues, which I deem this to be, can be a royal pain in the arse to figure out.
That said...
First, I'd follow the service manual's diagram on the starting wires lay out and those they intersect with. Making sure all the connections are seated well. All grounds are clean and tight.
If they are. That's when I'd start looking at parts.

Ride smart. Ride often!
 
1 - 4 of 4 Posts
Top