Yamaha Starbike Forum banner

1 - 20 of 30 Posts

·
Registered
2006 Startoliner
Joined
·
16 Posts
Discussion Starter #1
Just bought a 2006 liner With 15000 miles. Previous owner took for the most part good care of her. The neutral light does not work. Tested all the other safety switches. Everything works correctly. Just the N light is out. I think I have located where the neutral switch on the engine is located. I think I will have to pull the exhaust and 1 oil line not sure yet.

Do you think it is the neutral switch located on the engine that is keeping the light from illuminating?
 

·
Super Moderator "Loose Nut"
Joined
·
7,981 Posts
If the bike is starting, seems the switch it self is working. The bike would not start if neutral switch was out without you holding the clutch lever in. Sounds like the bulb is bad.
 
  • Like
Reactions: faffi and Boog

·
Registered
2006 Startoliner
Joined
·
16 Posts
Discussion Starter #3
I was afraid of that. I have searched the web and have not seen where any stratoliner have this same problem. A new gauge cluster is $600-$700 might just go without the light. Looked for a used one but nothing so far. Les do you know of any Online motorcycle grave yards?
 

·
Super Moderator "Loose Nut"
Joined
·
7,981 Posts

·
Registered
2006 Startoliner
Joined
·
16 Posts
Discussion Starter #6
Hey les or anyone else is the speedometer serviceable? Can it be opened and the lights be replaced or Are they a permanent micro led? Any place to send it to have serviced?
 

·
Super Moderator "Loose Nut"
Joined
·
7,981 Posts

·
Registered
99 Roadie
Joined
·
293 Posts
@Jaguartech , here's a question for you. ;)
First you would have to make sure it isn't a problem with the switch or harness.
Instrument comes out of its case easy.
Indicator bulbs on my roadie are quarter turn panel mount type.
Will get a bulb number and post it later.
Blackstrata, can you post a pic of the back of the circuit board of the cluster?
 

·
Super Moderator "Loose Nut"
Joined
·
7,981 Posts
First you would have to make sure it isn't a problem with the switch or harness.
Instrument comes out of its case easy.
Indicator bulbs on my roadie are quarter turn panel mount type.
Will get a bulb number and post it later.
Blackstrata, can you post a pic of the back of the circuit board of the cluster?
I knew our resident speedometer/odometer/dash expert would come thru. :unsure:
 
  • Like
Reactions: stratsurvivor

·
Registered
2006 Startoliner
Joined
·
16 Posts
Discussion Starter #10
Well the bike will start in neutral without pulling in the clutch. I did pull the tank panel and looked at the wire harnesses. Everything looked perfect. I did not unplug them all to look at the pins. Les did mention if the bike starts without pulling the clutch In that the neutral switch on the motor should be good. I have not tracked the wire from switch to speedometer yet to see if there is an issue with it. I have been researching where the wire runs. Looks to be a connector above the battery but everything looks good there as well.
 

·
Registered
2006 Startoliner
Joined
·
16 Posts
Discussion Starter #11
In all my years of being around motorcycles and ATV I have never known a N light going bad?
 
  • Like
Reactions: Boog

·
Registered
2006 Startoliner
Joined
·
16 Posts
Discussion Starter #12
I will post a pic of back later today. Thanks for the help!
 

·
Super Moderator "Loose Nut"
Joined
·
7,981 Posts
I had the neutral light go out on my 1100. It took a 24 bulb. Replaced all bulbs in dash with LED. Worked great.
 

·
Registered
99 Roadie
Joined
·
293 Posts
In all my years of being around motorcycles and ATV I have never known a N light going bad?
I knew our resident speedometer/odometer/dash expert would come thru. :unsure:
Expert?
Stretching it a bit🤣
Here's what was in a roadie.
Notice how l used the ink pen 😜😜
 

Attachments

·
Super Moderator "Loose Nut"
Joined
·
7,981 Posts
Expert?
Stretching it a bit🤣
Here's what was in a roadie.
Notice how l used the ink pen 😜😜
But it's not a black pen. 😂🤣
 

·
Registered
Joined
·
1,411 Posts
I am probably just a weird guy with a weird sense of humor but I find this kind of stuff funny...not groan button funny but funny nonetheless..(y)(y)😁😁😁
 

·
Registered
Joined
·
1,677 Posts
I found something, it looks like there is a diode block near the fuel cut off relay . if the one diode I have circled is bad , the bike will start in neutral but the light won't work.

97015
 

·
Registered
2006 Startoliner
Joined
·
16 Posts
Discussion Starter #19
I can do a lot of stuff but electrical I shy away from. Plus I am color blind. So what would that diode look like ? If it was bad would just the wire from switch to plug under seat need replacing? I saw in a schematic that the neutral switch wire went from switch on motor to a plug under the seat. Then from there to the speedometer.
 

·
Registered
Joined
·
1,677 Posts
Well being color blind sux in electronics trouble shooting.

You need to take a multi meter and with key on , ohm from the connector shown ( unplugged ) to ground ( battery negative)
switch back and forth in and out of neutral. It should be max ohms in gear to close to zero ohms in neutral.

97017
 
1 - 20 of 30 Posts
Top