Yamaha Starbike Forum banner

1 - 8 of 8 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
Hello everyone.. am new to the forum but I have been reading it for some time now.
I just purchased a second Roadstar 2006 Silverado, It has passing lights, but they do not work. I checked the bulbs and they are good, went into the headlight bucket and found a broken wire going to the passing lights, but repairing the wire still no power coming into the headlight bucket.. have been trying to locate the passing light relay but can't find any reference to where it is located so I can test or replace it..
Would much appreciate any help from this forum.. photos even more..:grin:


Eddie in Texas
 

·
Moderator
Joined
·
2,369 Posts
Welcome from Atlantic Canada, Eddie. Geez, you Texans are gonna need your own chapter here soon - lol. I have an 1100 so I'm afraid I can't help much with your problem but if you post it in the appropriate forum it'll get more exposure and I'm sure someone will chime in.

Post a picture when you get a chance - as you may know we're kinda big on pics here.
 

·
Super Moderator "Loose Nut"
Joined
·
5,067 Posts

·
Super Moderator
Joined
·
6,266 Posts
Hi Eddie!
Welcome from East Tennessee.
NorthernRider is dead on, the Vstar section is the best place for your mechanical issues, etc. I’m planning to add some passing lights to my wife’s 950 soon and plan to do a thread on it.
Keep us updated on your progress as may help some others as well.


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
3 Posts
Discussion Starter #6
Passing lights NOT working

Thanks for the replies, I will move my question to the Road Star forum..
Just to let you know I have checked all the fuses.. I really would like to know the location of the Passing Lights Relay on a 2006 Road Star, if anyone knows the location.

I am in middle West Texas (San Angelo)


Eddie in Texas
 

·
Registered
Joined
·
251 Posts
Welcome...the small toggle on/off switch is notorious for going bad and likely the issue. You can bypass the switch and wire to stay on all the time as your easiest option. I’ve had three switches fail and then bypassed the toggle. I tried to find a replacement switch at radio shack without much success.
 

·
Registered
Joined
·
675 Posts
Hi Eddie!
Welcome from East Tennessee.
NorthernRider is dead on, the Vstar section is the best place for your mechanical issues, etc. I’m planning to add some passing lights to my wife’s 950 soon and plan to do a thread on it.
Keep us updated on your progress as may help some others as well.


Sent from my iPhone using Tapatalk
I just added a set of OEM passing lamps to my 09 V Star 950. They were tough to find but as usual Ebay and Amazon got me what I needed. Not too bad to install. Wiring is pretty straight forward. I have to say the hardest part was putting the wiring back in the head lamp bucket so I could remount the lens. Good luck with it! My next task is to install a mod to my rear lamps to make the turn signals running lamps and the brake light flash a few times. I may add additional led lamps to my saddle bags if I still feel more lighting is needed.
 
1 - 8 of 8 Posts
Top