Yamaha Starbike Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
so I have a 1981 Yamaha 650 and the oil light came on and now the electric start won’t work? And ideas?
 

·
Registered
Joined
·
4,824 Posts
Welcome from Wisconsin. Is that a virago? I am not sure what it will be but i am sure others might be able to help you. Did you run it with the light on or did it just come on? Good luck and let us know what you find. Stop by often.
 

·
Registered
Joined
·
6,851 Posts
welcome to the forum

sorry your first post is under distress

did the oil light come on while you were riding, and did you keep riding it?

Is it really a 1981 or was that a typo - Yamaha did not make a 650 Virago, they were 750s, and Vstar 650 bikes only go back to 1997

reason I ask is the Vstar 650 does not have an oil light

Vstar bikes will not start if the kick stand is down and the bike is not in neutral,

if your kickstand is up, or the bike is in neutral, its possible one of those position switches has failed


IF you were riding the bike and the oil light came on (Virago 750) and you kept riding you may have seized / blown the engine

please provide more details so we can narrow this down
 

·
Super Moderator
Joined
·
3,075 Posts
Welcome from Sacramento, Ca.
 

·
Registered
Joined
·
1,680 Posts
Welcome from Columbus, OH! Lots of good information here. Snoop around and enjoy the forum!
 

·
Super Moderator
Joined
·
3,936 Posts
Welcome from Atlantic Canada. Sorry you're having problems but we'll do what we can to at least narrow down the cause. I'm guessing it's a 650 Maxim?
 
1 - 6 of 6 Posts
Top