Yamaha Starbike Forum banner

1 - 11 of 11 Posts

·
Registered
Joined
·
10 Posts
Discussion Starter #1
HI I bought my 2002 Vstar 1100 in September of this year at the end of the riding year. This is my first import bike, so is there anything i need to know about these bikes maintenance and other info would be greatly appreciated.
 

·
Moderator
Joined
·
1,625 Posts
Welcome from Sacramento, Ca. I had a 2002 1100 Custom and loved it. Put 78,000 mile miles on it with very few issues.
 

·
Registered
Joined
·
1,627 Posts
Welcome i just happen to have a 2001 1100 classic myself. After a life of riding mostly Honda i found my 1100 classic this spring and fell in love with riding all over again. There are a lot of guys around here that know everything about these bikes. The 650 is the most common. The only problem i had with mine was i needed to put a voltage regulator in mine. Mine was put up for the winter about a month ago because i had hernia surgery, but i snuck it out last weekend because everything with the weather fell perfectly in line but i am pretty sure it was the last time out this year. Usually my bike comes out atound St Patrics day. I am waiting along with you for spring
 

·
Super Moderator
Joined
·
6,262 Posts
Welcome to the forum from East Tennessee!
Lots of 1100 owners here and from what they say, they’re pretty much bulletproof. I’m sure some of them will chime in.


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
10 Posts
Discussion Starter #6
Ya i bought it to do a memorial ride for a fallen veteran in September. I bought it on a Wednesday and Saturday was the ride. it rained for two days so i only had a day to get familiar with the bike, I had a blast. On the Saturday early I went got my bike and my other friends bike ready for the ride. Jumped on mine battery dead, so I threw the charger on it. The charger was on it for about 5 hours and it said it was charged. I figured that i didn't turn the key off all the way. Started the ride and road the Missouri river made it about 100 miles battery dead on the side of the road and the speedo spun all the way around. I was not happy. On the ride someone had a trailer so I pushed it on it and finished the ride in the pickup. Took the shop that next Monday to find the bike with a flat front tire. They did not find anything wrong with the charging system, but found water in the fuel system. Got the bike home after 2 weeks rode about 15 miles front tire flat again. So out of anger i but it away for the season, so I have no idea if the charging system is working.
 

·
Registered
Joined
·
164 Posts
Thank you. I wish I could ride all year round. I live in South Dakota, so no riding for awhile
Welcome to the forum from a newbie rider and used VS650 owner. Like you, my bike is sitting out the winter with plans to catch up on the maintenance schedule come spring. Happy trails.
 

·
Registered
Joined
·
668 Posts
Welcome from Columbus, OH!.. Since you live in South Dakota you will have plenty of time to get some of the issues you had resolved before riding season get here. I would suggest fresh tank of gas along with a fuel stabilizer, a battery tender,a cover of some sort even if storing it indoors, a cover to put over your exhaust pipes to keep the critters out, and some carpet under your tires. If you tear into your electrical system I would suggest some dialectic grease for the connections..Since you are already there it will be time and money well spent. If you have any questions or get stuck on something there are many mechanical and electrical wizards here who will help in any way they can. Good Luck!
 

·
Moderator
Joined
·
2,366 Posts
Welcome from Atlantic Canada. I also had an 1100 (2000 vintage) and it was a great bike. I only sold it because I wanted something bigger.

Your issue could also just be a bad battery. They usually have a 3 to 5 year lifespan. I suggest having it load tested and go from there. Post the results and we'll help you get it sorted out.
 

·
Super Moderator "Loose Nut"
Joined
·
5,066 Posts
Welcome from Houston, Texas. Glad you joined us. Here's a few interesting threads to check out when you get a chance.

https://www.starbikeforums.com/forums/49-v-star/5655-yammy-ya-got.html?highlight=Yammy




Go to last page for current hunt :

Ride often and safe.
 

·
Registered
Joined
·
1,627 Posts
Did the odometer flash also? I had the same thing happen after i got my 1100. Have a load test on the battery. Mine turned out to be the rectifier/regulator. All of the tests pointed to the fact that it was ok. Reinstalled and it turned out to be intermittent. It seemed that when it started to get warm it would stop charging. It turns out that this is a known isse with these. Against everything that everyone here told me is don't buy a cheap one. I am cheap and bought one $14 on ebay and it has been fine. The attachment shows signs of heat deterioration
IMG_20190615_173134.jpg
 
1 - 11 of 11 Posts
Top