Yamaha Starbike Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
94 Posts
Discussion Starter #1
So after totalling my car last Thursday my motorcycle starts to have issues with the turn signals flashing like hazard lights on one side.

I tore everything apart and have found the previous owners did install LED turn signals and brake light.

I don't know anything about motorcycles so bear with me.
In the testing I've done it appears the Red module on the left side is bad. (see picture)
The problem is I don't know what it is.
My guess is it's something related to the LED lights that were installed.
I've had this problem in the past but I was able to clear it up by cleaning or drying out the switch on the handlebars.
This time it hasn't worked, so I'm working with the wiring they have under the seat.
I can make either side of the lights work like normal if I connect them using the red module on the right side.
But the left side doesn't do anything.
If anyone knows what it is that would be helpful.
Thanks for the help,
 

Attachments

·
Registered
Joined
·
94 Posts
Discussion Starter #4
what is it some type of resistor?
Yes,
Its for one side of the turn signals.
The other works fine on either side of the turn signals.
This seems to be the source of my issues so I'm trying to find a replacement.
The problem is there isn't any information on it so I'm guessing on what to replace it with.
Hopefully I won't blow something in the process of fixing it.
 

·
Registered
Joined
·
1,494 Posts
its big,so are the wires.if its marked how many ohms maybe radio shack can get you something.do you still have self cancelling turn signals?if these are used to slow down the fast flashing that comes with led turns if you cant get a replacement maybe a two wire flasher would do the same thing.
 
1 - 5 of 5 Posts
Top