Yamaha Starbike Forum banner

1 - 3 of 3 Posts

·
Premium Member
Joined
·
155 Posts
Discussion Starter #1 (Edited)
Brief history, rejeted carb, set PMS as per the wiki page at 2.5 turns out and the bike ran great for over a year. The idle droped on the bike, missing at idle and popping when letting off throttle, signs of running lean. I realize that once the PMS screws are set no further adjustment should be needed but I thought I would check anyway and sure enough, on the rear carb the idle picked up when I turned the screw and the bike ran great until yesterday when the same symptoms reoccured, idle droped on the bike, missing at idle and popping when letting off throttle.

I pulled the carbs today, removed the PMS screw and could not identify anything that could be causing the problem, I then blew the screw hole out with the compressor and ordered the Maxair PMS screws. Is there anything else that I should do before reassembly?

Thanks,
 

·
Premium Member
Joined
·
155 Posts
Discussion Starter #2
Back together after blowing out the pms port with a compressor and installing the Maxair jets and although it is better there is still some backfire when down shifting and slowing. I guess I will pull the carbs again, disassemble and soak them in carb cleaner. I might wait till the heat of summer, weather is just too nice right now to be down.
 

·
Premium Member
Joined
·
155 Posts
Discussion Starter #3
Together again after disassembly and a thorough cleaning and bike is running great.
 
1 - 3 of 3 Posts
Top