Yamaha Starbike Forum banner

1 - 8 of 8 Posts

·
Registered
Joined
·
20 Posts
Discussion Starter #1
I just bought a new Raider scl #14 and i've put about 500 miles on it. While driving it two days ago the speedometer "stuck" at 30mph. I pulled over, shut her off, turned her back on and it stayed the same. Got back home right before the rain caught me. Came out the next day to ride and after turning the key (still stuck at 30 before i turned the key), she went back to normal. Two more days of riding has not duplicated the problem. Only thing i've noticed before and after this incident was that the fuel needle would not immediatly move after fuel was put in. It would "catch up" 20 minutes or so later down the road. Any previous problems like this been reported by other Raider owners?
 

·
Premium Member
Joined
·
2,503 Posts
I believe 30mph is the listed safe top speed for the Raider . . . . :D

You've got me on the speedo issue, but I would damn sure head for the dealer if it happened again (and take some iphone photos and video if I couldn't get there directly).

As for the fuel gauge, I don't know about the raider, but the Roadliner / Stratoliner twins of the Raider specifically say in the manual that the fuel gauge does NOT adjust immediately after fillup. I've forgotten the exact line in the manual, but I believe it is 3-5 miles before it adjusts (I also figured mine was broken).
 

·
Registered
Joined
·
20 Posts
Discussion Starter #3
I believe 30mph is the listed safe top speed for the Raider . . . . :D

You've got me on the speedo issue, but I would damn sure head for the dealer if it happened again (and take some iphone photos and video if I couldn't get there directly).

As for the fuel gauge, I don't know about the raider, but the Roadliner / Stratoliner twins of the Raider specifically say in the manual that the fuel gauge does NOT adjust immediately after fillup. I've forgotten the exact line in the manual, but I believe it is 3-5 miles before it adjusts (I also figured mine was broken).
lol, if 30 is safe than i've bought the wrong bike. I'n no speeder since im over 40 now, but im not dead yet either. thanks for the info on the fuel needle deal. That sounds similar to what happeded with me. Deff taking pics/video next time it happens...
 

·
Registered
Joined
·
22 Posts
I haven't had any issues yet. Sounds odd, like something is sticking inside the gauge. May also want to make sure everything is plugged in well. I haven't take mine apart, but I'm assuming it's an electric speedo?
 

·
Registered
Joined
·
61 Posts
Have you done any work which required removing the dash? If so, check the connector. If you've not had any problem since, you're probably OK. And yes it is electrical.

As far as the fuel gauge goes, every Raider's gauge is as you describe. Kinda jumps around a bit, reads low then jumps to where it should be later. I don't have any gauge issues but I use mileage as my fill-up guide - after 100 miles or so.
 

·
Registered
Joined
·
153 Posts
Due to the angle of the tanks the fuel gauge acting like that is pretty normal but the speedo sticking like that isn't I would keep an eye on it if it continues definately bring it in to the dealer. Like the prior post did you do anything to the speedo like change the face or anything?
 
1 - 8 of 8 Posts
Top