Yamaha Starbike Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
Hey all! New member here, just got a 07 v star 1100 and one way starter clutch went bad, $1200, and 2 weeks later, and now have issue with slipping clutch whenever I get on it full throttle. Will try the lower adjustment procedure, then if that don’t work; will look into installing new clutch kit, about 1 hour job? Anyone have link to where buy clutch kit? Appreciate any advice and or info!
 

·
Registered
Joined
·
512 Posts
Welcome from Columbus, OH! Stand by as I am sure help is on the way from other forum members. In the mean time snoop around and enjoy.
 

·
Registered
Joined
·
5,384 Posts
spend the time making sure your clutch has 1/4" or more of freeplay at the grip, and look at the engine end carefully and make sure the cable is not frayed, or just needs to be lubed

its sucks to replace your clutch and then find out the cable just needed a spritz of white lithium grease
 

·
Super Moderator
Joined
·
4,515 Posts
When was the last time you changed oil. What kind and weight of oil? None JASO oil will case a clutch to slip. Too light of a weight will also case clutch to slip. Most of the time proper adjustment will eliminate slipping. Post back results.
 

·
Super Moderator
Joined
·
6,019 Posts
Hi Kerry!
Welcome from East Tennessee. You’ll get more responses in the Vstar section as this is for new members to introduce themselves. You’ll get lots of information.


Sent from my iPhone using Tapatalk
 
1 - 5 of 5 Posts
Top