Yamaha Starbike Forum banner
1 - 14 of 14 Posts

·
Registered
Joined
·
160 Posts
Discussion Starter · #1 ·
I have a 09 950 with about 4k on it. Last week I went on a 1500 mile trip and my speedometer is not even close to accurate. After riding 100 miles on my odometer, my wifes odometer read 97 mi. I checked it with my GPS and it is about 6 mph off at 65. Is this adjustable or do I have a defective part somewhere?:confused:
 

·
Registered
Joined
·
22 Posts
This is absolutely the norm on motorcycles. The spedo difference ranges from 5 to 10% depending on the bike. Our 950s are about 8% off, meaning that at 100kph your doing about 92. I use my GPS for accurate spedo info, otherwise, I don't worry about it.
 

·
Registered
Joined
·
1,530 Posts
You could adjust with a Larger tire. A 200 width with the same aspect ratio would give you about 6%.
 

·
Registered
Joined
·
410 Posts
It is much better to think you are going faster than you really are. I set the speedo at 70 in a 60 zone and have never gotten pulled over. Only when I set it at 70 in a 40 does this happen. OOOPs
 

·
Registered
Joined
·
119 Posts
Every bike I have ever owned has been this way.
I don't know if a Speedo Healer is available for these bikes but I run one on my R1 which allows you to "correct" for the % of error in the factory set up and have the speedo display the correct speed.
 
1 - 14 of 14 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top